Download

Changing FOV in DefaultEngine.ini does nothing

I have the following settings in Default.ini:

Nothing happens though. Is there anything else to do to get that FOV in the Rift?

For VR, FOV should be set automatically since it needs to exactly match the headset geometry and lens setup. It’s not a user preference - if you change it away from the single correct value, the world will warp and bend as you turn your head and this is very nauseating.

If the FOV you get by default is wrong, that’s potentially a bug. Do you have more detail about what’s going on?

I don’t think there’s a fixed FOV for the Oculus Rift. Even the Wiki mentions a higher FOV to counter sim sickness: A new, community-hosted Unreal Engine Wiki - Announcements and Releases - Unreal Engine Forums

The fact that the Oculus settings include FOV also points to that. Or maybe I’m just misunderstanding things?

The wiki entry is very misleading. Having a bigger FOV is more immersive, but only if you actually change the headset’s lenses or use bigger screens to make the physical field of view bigger, not just adjusting the FOV angle in software by itself. I’ll look into editing it. From Oculus’s best practices guide: OK | Oculus

I’ve edited the wiki entry, adding links to Oculus’s best practices guide and to a GDC talk: A new, community-hosted Unreal Engine Wiki - Announcements and Releases - Unreal Engine Forums

If you haven’t seen Tom Forsyth’s talk yet, I highly recommend it. Very informative and also entertaining. Everything you ever needed to know about preserving VOR gain (why changing FOV is a terrible idea), floor dragging, meathook avatars, and lots of other fascinating topics: http://www.gdcvault.com/play/1020714

Thanks for clarifying, makes sense now! I wasn’t really unhappy with the 90°, just wanted to see what it looks with more as I could have sworn reading about positive effects of increasing FOV in the Oculus forum, but can’t really find anything now so I guess I must have been dreaming.

This may well have been true for a specific case, but it would mean that there’s a bug somewhere - my guess would be that a specific app did something strange, but it could also be due to misconfigured settings in a user’s Oculus profile, or potentially a bug with the way UE4 integrates with the Oculus SDK. I don’t want to discourage you from experimenting, but it’s definitely not a “more is better” setting.

Well we can’t experiment as neither the UE4 camera FOV inside blueprint nor the setting in the ini file seems to do anything. But no worries, and either way those comments I may or may not have read in the Oculus forum would have been about Unity as UE4 wasn’t out then.

Not 100% sure but isn’t there also a bOverrideFov property that needs to be set as well?

Have you guys already seen this Getting Good FPS and Quality in UE4 Demos on Oculus Rift DK1 - YouTube from eVRydayVR?(Not sure he posts here)

He’s changing the distortion scale to change FOV, smaller FOV actually leads to a less blurry image in this case. Also note the description with a link to his patch to save those changes in the .ini

(I see his method has already been discussed in another thread here)

Interesting to see it in action. I think the guy is just doing this: http://www.reddit.com/r/oculus/comments/24g92u/guide_to_getting_good_fps_and_quality_in_ue4/

But I also think this hasn’t got anything to with actual camera FOV that we were talking about here. The guy calls it FOV but it seems what he means is more like the visible size of the image, meaning how far out the image is rendered before it turns to black.

Edit: oh that actually IS the guy from Reddit.