Download

Changes not running on headset

This is a problem I haven’t seen before. I opened a project today, and made a change to one of the materials used on a box. I have changed this material before several times without problems. Now, when I launch the app, the changes aren’t reflected on the headset when it runs. I thought maybe the texture was cached or something, so I just added a debug print to one of the blueprints, and that doesn’t show either. So it seems there is some cached version being send over to the headset.

I tried deleting the APK in Binaries\Android\ but that didn’t help. Whatever it builds again is the old texture and no debug print. Also tried deleting the ‘Intermediate’ folder but that didn’t help either.

If I Simulate the game, it looks as expected.

I do see 2 warnings which I don’t remember seeing before :

WARNING: Excluding [gamename]/Saved [gamename]/Config Engine/Saved Engine/Config from clean during deployment.
WARNING: Deleting APKFileStamp.txt from device; not found in staging area

Anyone know what is going on and or how I can fix this?

Have you switched between development and shipping builds? Try uninstalling the app from the device and trying again.

Ya I did that. I also went into ‘Files’ on the headset and deleted everything in there (in the UE4Game folder). Restarted UE4 too, nothing helped. Only thing I did differently was in the World Outliner panel, I created some folders and moved objects into them to clean things up a bit. Not sure why that would hose things up.

I’m not sure what you did would hose it that way. I get a sorta similar issue if I switch between shipping and development without running the uninstall batch file in-between.

I don’t even know how to switch between shipping and development. I just hit the Launch button in the editor and it sends it to my Quest. This is how I’ve always done it and never had issues until now.

Ahhh, I always find Launch a bit flaky. I always package the project then upload it to the device with the generated batch file. You could try that?

Well I manually deleted the APK file and when I launched it, I could see a new one created, but it still wasn’t updated on the device. I have to assume it was this newly created one that was being sent over? since I didn’t see any others. But I could try your way and see what happens.

Good luck!

Ok so today I loaded the project and packaged/installed it. The changes are there on the headset! Further, using the Launch button now, after make more changes, they show up on the headset.

So now I am totally confused. I didn’t reboot the computer or make any other changes. Either something was in memory that cleared, or the packaging triggered something.

Anyway, thanks for your help. This is good to know going forward.

1 Like