Change the precision of the navmesh

Hello,

The agent radius property seems to be what are you looking for. This property specifies the radius of the smallest agent that can traverse the navmesh. If you increase this value the gap between the navmesh and the objects increase so that the agents can walk.

See these images below:

This one with an agent radius of 35.

And this one with an agent radius of 100.

Hope this helps,

mtrebi.

[Update: Max Simplification Error]

In fact if you want to increase the accuracy of the shapes you can tweak the Max Simplification Error parameter. This parameter specify how much navigable shapes get simplified.

I would do it for coherence but I don’t think you can have any problem if you don’t do it. However, I think that the capsule size of the AI Agent must be smaller than the Agent radius of the Navmesh to avoid problems.

If my answer was useful and it worked mark it as an answer. Thx!

Hello!

I´ve been messing arround with the navmesh and its settings. Im trying to increase the precision of the navmesh.

Let me show you an image:

What Im looking for, is to increase the distance between the wall and the navmesh.What property should I change?

Thanks!

Hey!
Thanks for the response!

It seems to detect the param when I change it in the “RecastNavMesh-Default”,but when I update it at “Settings->Project Settings->Navigation Mesh->Agent Radius”.

Also,shouls I change the capsule size of the AI Agent?

See you!

Ok! I ill try it :smiley:

Not sure how to do that :s

Do what? If you mean to mark the comment as answer you just have to mark the check below the start of my first comment (above).

piluve and mtrebi:

Interesting conversation between you two.
I am using UE4.14.3 and Tom Looman’s VR template in a VR model and tried to decrease the agent radius to less than 10 so it could flood into a crowded room with objects that have collision parameters. These objects are Blueprints and will eventually be picked up and located in various configurations. With the Agent Radius at the default 35, the NavMeshVolume does not enter this room and therefore, I cannot navigate with my HMD and controllers. Vive HMD and controllers and Mr. Looman’s VR template. I am thinking that the collision parameters on each blueprint are preventing the NavMeshVolume from entering the crowded room. When I set the Agent Radius to less than 10, the green volume enters the room, but the teleportation aspect of the VR template does not work. Stumped.

Any ideas?

Art in Seattle

Decreasing cell size also helps (Project settings>Navigation Mesh>Generation>Cell Size). Just don’t set it to 1, as it the calculation takes too long. Decreasing the cell size allows the agent radius to have an affect. My default cell size did not allow any affects of the agent radius. If the cell size is set to “5”, for example, then the agent radius is changed, it will have desirable results.

Anyone knows how much can affect or help creating static meshes that have either simple collision boxes or the geometry by itself should be simpler?

The best I get when using Cell size 5, agent radius 5, is it possible to further improve it?

Is it possible to affect the nav mesh with only a Box Collision and the Can Ever Effect Navigation property checked in?

I am experiencing failed path finds after tweaking the cell size and agent radius values. Is there any where in the official doc describing if this is the case and how it can be fixed?

Not exactly sure about that one. I’m thinking of increasing my own cell size as it takes a noticeable amount of time to update, and I’m worried that it may affect in-game performance with dynamic actors which can affect navmesh. Maybe try increasing the “max simplification error”? It should fill in some of the rounded corners and also be cheaper.