Change RenderTarget Alpha to 0 past max view distance

I am using an actor component: rendertarget2D, with a max draw distance of 400.

The sky still draws in the diffuse channel and the alpha is white - the sky is much farther away than 400.
Is this a bug or an oversight?

I would imagine that the alpha should be white for stuff in front of the max draw distance and black for stuff past the distance.

I tried setting up a green screen material on mesh behind the actors captured by the rendertarget then using in the material a Blend_Exclude and it works up to a point, but maybe I can do the shader set up better, without losing color from the original texture.
I attached an image in case anyone is interested in green screen.

Hey, did you find out how to exclude the sky without the color keying?

ah no - i totally forgot about this case…