Download

Cave Lighting

I have a cave asset under the terrain that I don’t want to be lit by the skylight or ambient. It should be dark unless a dynamic light enters it.

I’ve looked in all kinds of places, I assumed there would be something in the model properties, to exclude lights but did not find anything.

Any ideas?

The way the skylight works you shouldn’t have an issue with your assets under the terrain unless it’s getting light bounces. The biggest thing here is to make sure that if you’re getting light leaking or lighting where you would not want it to have meshes behind your cave mesh to help block this light. You can see that in the Realistic Rendering demo on Marketplace we’ve set that up to help block light as well.

There is no way in UE4 to exclude specific objects from certain lights though. From my understanding this is not possible with deferred lighting.

In the images below These are two setups and they look identical. One with a skylight and dynamic light and the other without a skylight and a dynamic light.

With Skylight in scene
575ade373684c7b0fdadebfdbebbce756342823c.jpeg

Without Skylight in scene
83ac698cb6fa3040934e7fa47cec9a6b60ea4db1.jpeg

For the ambient option you can always used a post process in the cave area so that when you enter it will disable the post processing effects you do not wish to have, such as Auto Exposure (aka. Eye adaptation). This will keep your cave nice and dark!

If you have any questions feel free to ask! :slight_smile:

Tim

I have a similar issue. I’m using LPV dynamic lighting with an ambient cubemap and skylight to get the outdoor look I want. My underground rooms have geo surrounding them to block the dynamic sun from the day/night cycle but there’s still ambient light in the scene from the ambient cubemap. I need it pitch black and it’s multiplayer so I can’t just change the lighting globally when a player enters it. When you suggested a post process in the area to get rid of effects, would that also turn off the cubemap?

You have the option in the post process to adjust the intensity and the cubemap texture for each post process. You could apply another cubemap to apply to this area with the post process and/or adjust the intensity level that you like.

I hope this helps! :slight_smile:

Tim

I even tried exporting a box, completely sealed and when I stand inside it, the interior faces are lit.

Is there a debug view/mode for seeing what objects are being lit by what sources?

I just tried this as well with two boxes. The outer one regular with normals facing outwards and and inner box with normal flipped so I could stand in in. It’s still ambient lit inside. What am I missing here? I used a new Post volume and turned down the ambient cubemap to 0 but I think my global level one is still affecting it(?)

Sorry if I revive this old thread but is there any solution to it ? How are caves in Ark: Survival Evolved being lit ? Let’s say you’re creating a Multiplayer game, dynamic lightning, fully Day/Night cycle (like Ark) and want some nice caves, how would you approach the lightning of those caves ?