Download

Cast shadows but not light?

Is there a way to just cast a shadow but not the actual light? The specular light hot-spot is annoying!

Thanks

No, you can’t have a shadow cast without light, I’m not even sure what that would look like visually

Well, it would affect the scene the same way as ambient occlusion does. What I could do with is a shadow g-buffer to multiply over the scene. Unfortunately, even if there was one, I’m using the forward renderer. So really it’s a material trick I need. I want my surface which the shadow falls on to be fully rough with regards to the light source, but reflective to the environment map and reflections (planar)

https://answers.unrealengine.com/questions/452833/remove-spotlight-reflection.html

Thanks @redbox

I did fiddle about with that but unfortunately i was using the forward renderer so it did nothing! I’m now thinking i’m going back to the deferred renderer - it’s a shame because I really need the sharpness and performance for my project (live TV), but I just don’t have all the features I need in the forward renderer yet.

Set the specular value in all of your materials to 0. That will remove all highlights.

That would disable all reflectivity.

Min Roughness is supposedly broken in the Forward renderer right now(Unreal Engine Issues and Bug Tracker (UE-42488)). Can you bake your lights? That will remove the Specular contribution of the lights themselves, but not affect the materials or reflections.