Cascade spawn rate - distribution float constant curve not working as expected

Created a new particle system, clicked the Spawn module in the default Emitter. Then in the Details panel, under Spawn…Rate…Distribution selected ‘Distribution Float Constant Curve’. Then I clicked the little graph icon on the Spawn module and set a couple of points in the Curve Editor. For this example, first point is at time 0 with value 1 and second point is at time 2 with value 5.

With the curve described above, I would expect 1 particle/second at start and then after 2 seconds it should increase to 5/second. Instead, it seems to be taking approximately the average of the two values and producing about 3 per second the entire time.

The Lifetime module seems to have the same sort of behavior.

Am I doing something wrong? How else would one change the spawn rate over time?


Still would love to get this working the way it seems like it ought to, but did a workaround in C++…

For anyone else wanting to do that, use a ‘Distribution Float Particle Parameter’ and change its value in code. De-select ‘Can be Baked’ or else it just uses the value in ‘Constant’.

i am experiencing this same issue. It seems to act this way for anything where the curve relies on the emitters lifetime being longer than 1. Anything from 0-1 works as expected but anything set to change over the course of more than 1 second just doesn’t happen. I most recently had this issue with velocity cone’s velocity property. I wanted it to slow from 500 to 0 over the course of 4 seconds to simulate loss of pressure. Instead it slows a little, then stays constant until dropping off at the end.

For me it works fine when I use “Rate” AND “Rate Scale”.

Rate: 1 Particle
Rate Scale (Constant Curve):
0s = 10 Particles
8s = 0 Particles