Cascade: Initial Location (Seed) module bug?

I was attempting to make a “grid” of particles using the Initial Location (seed) module in cascade, when I came across a strange issue.

I set the parameters to evenly distribute particles across a space with these parameters:

Spawn Burst: 11

Lifespan: 0 (live forever)

Initial Location (seed):
Min X: -100,
Max X: 100,
Distribute over N Points: 11,
Distribute Threshold: 1.0

This worked almost as expected. The problem was that every time the particles were emitted they didn’t fill all of the equally spaced points. It would fill several points, and leave some blank. It would put multiple particles on one point, leaving others empty. I tried adding a seed value to see if I could find a value that filled all the points, but I think the seed is broken in this module. It would still fill random points each time the particles spawned. I tried upping the burst count, but had to crank it way up to fill most of the points and even then there would be occasional gaps.

I tried using the seed in the Cylinder (seed) location module, and that gave the same distribution every time, so I think it’s just broken in the Initial Location (seed) module.

~Mike D.

can confirm this on 4.11

You’d expect that a seed would fill in the same npoints each time.
It doesnt.