Download

[Cascade]How to set the particle seed?

I have a cloud particle system. I want to put it on my map, but I want it to have always the same shape. So, in all modules of the particle with random values, I used the “seed” version, as you can see here:

(I don’t know if I must check the “Get Seed from Instance”, I didn’t understand the documentation about this checkbox… but it doesn’t matter, it didn’t work anyway) (all the “Seed” modules contain the same “Seed” parameter)

But here are two instances, with the same seed (10), looking completely different from each other:

Here is a screenshot with one of the instance’s settings:
2instanceparams.png

What’s going on? I also tried to set the parameter on a blueprint, but it didn’t work…

You need to add the random seed.

&d=1484663779
that image, “Random Seeds” has a + sign, if you press on that you can add a seed and a value.

Thank you Luos, it actually worked! But I confess I didn’t understend why… I mean, the random seed is not the value I pass in the exposed parameter? Why I have to add a value to the array? I’m just asking for curiosity, because it’s working now.

Unless you make a seed-array in blueprint (but I dont have enough blueprint experience to explain that part), you are actually creating a list of potential seeds. so the more seeds you are creating, the more random seeds the module can pick :slight_smile:
So if you only add one seed, it will always be identical.

This is handy to pick a few seeds that you know will always look well, instead of hoping it will always look good.

But I added only one seed. With the value 10 on each module.

And I can now have many variations because I am exposing the “Seed” parameter to my instances. I set each instance with a different value and now I have many instances, all different from each other.

So, I’m not using the seed I added into each module’s array, because I am using the parameter. This was not working before I added the value to the arrays, for no reason - I think.

It’s working perfectly now, but it looks like a bug for me, isn’t?

It looks like a bug for me as well. By the way, thanks for your post. I had the exact same issue.

It might not be a bug, but rather a result of the unfortunate UI.
See the problem is that just because you provide a parameter name for the random seed info does not mean that the particle system also has a parameter set at runtime.
But then what should the result look like when I retrieve a value from the FRandomStream* in the particle module? As long as there is no default value, the behavior is undefined.
By adding an element to the seed array you provide it with a default value and it can be initialized to be used by the particle system in all cases.