Can't use my plugin in a only blueprint project (missing or incompatible module).

Hi all,

i made a Blueprint Function Library plugin where i put some “service” code for my blueprint actor, all work fine and gg.

Now i want to distribute my plugin and i followed what the [documentation say about it][1], i deleted the “intermediate” and “source” folders, after this i created a Blueprint only project to test the plugin, i copied the plugin folder into the project folder like this

but unfortunately when i launch the project i have these messages:



here my .uplugin content

	"FileVersion": 3,
	"Version": 1,
	"VersionName": "1.0",
	"FriendlyName": "MusicPlayerLib",
	"Description": "Service functions for music player actor blueprint.",
	"Category": "Other",
	"CreatedBy": "Yuri Belleri",
	"CreatedByURL": "",
	"DocsURL": "",
	"MarketplaceURL": "",
	"SupportURL": "",
	"EnabledByDefault": false,
	"CanContainContent": false,
	"IsBetaVersion": false,
	"Installed": false,
	"Modules": [
			"Name": "MusicPlayerLib",
			"Type": "Runtime",
			"LoadingPhase": "PreDefault"

Any idea on where is the problem? Or can i use distributed plugins only with C++ projects?

Did you compile plugin binaries for Win64 Development configuration before you deleted the Source directory?

Yep. I exactly done what documentation say.

“Solved”, it work only if i compile in “Development Editor” instead of “Development”, not tried before because i was sure (and in 4.10.4 was it) had to share the source code too, instead it work too.


Still broken on package project, i give up and i will distribute the source code, very sad no one have a solution for this :frowning:

I read somewhere that you need to leave the build.cs files in the source folder. You cannot wipe out the entire source folder