Can't Set Simulate Physics C++ [Solved]

So I have a parent Pawn who takes input to move left and right and a space bar to jump, this is then received by the child pawn and addForce is used to make the jump, but it constantly says simulate physics needs to be enabled.

As you can see I set collision and simulate in code, yet in the blueprint view there isn’t even the tickbox to activate physics.

What is going on?

First, to see all the other stuff in the Physics Pannel, you need to change the UPROPERTY from EditAnywhere to VisibleAnywhere.

Second, make sure your root is also capable of having physics enabled.

Third, I would also enable gravity.

Fourth, make sure you set up your Mesh correctly (adding collision for example).

Fifth, if it’s still not working, I would try to wake up the rigid body.

Let me know if that works for you! <3

Great thanks for that, I’ll give those a go.

Hey thanks for the reminder. I changed the property to visibleanywhere which revealed the tick boxes for physics and gravity. I ended up adding a box collider as the root.

I had the same issue. In my case, the BP derived from the C++ class did not have “Physics - Simulate Physics” option checked. Once I enabled the check box of the BP, things started working fine. I’m confused as I thought this should’ve been done by default as the super class does so…

I removed below code from ABatteryPickup class and just checked the simulate physics option
from BP instance worked. Strange…

1 Like