Can't select static meshes in viewport in some display modes

After taking a bit of a break with UE4, I just updated to the latest build, and found out rather quickly that I seem to be unable to select static meshes in the perspective view in a lot of the display modes. The biggest problem is that it also happens in the ‘Lit’ mode, meaning I need to switch to unlit to select a mesh.

After quickly trying some settings, turning on the flag for “Show collision” fixes it, but also obviously puts wireframes over everything.
Hover highlights also don’t work in the same scenarios. But again, only for static meshes.

Bonus info:
I was using the starter content architecture meshes, but tried importing a mesh with the same results.

System specs:
Windows 10
Intel i7 4770
Nvidia GTX 980 Ti
16Gb RAM

Hello mktwo,

I have tried to reproduce your issue, but was unable to do so. Is there any other information that you can think of that may be helpful in trying to reproduce the issue that you are experiencing?

Have a great day,

Sean Flint

Hi Sean,

Go figure, I went to open UE4 to do some more testing with different versions and settings, and it somehow fixed itself! I guess something I did yesterday might’ve required a reboot and caused issues. Consider this bug report obsolete :smiley:

This happened to me, too. I duplicated an existing scene and suffered the same issue as mktwo. Closing and reopening Unreal solved it. Although the fix is simple (Close and Reopen UE4), the bug is valid. Thanks.

Just happened to me too, 4.12.5, can’t select static meshes in certain view modes, InstancedFoliageActor selects fine and certain components of actors placed in the scene such as lights, arrows, splines and UMG Widgets but not their meshes.
After quickly going through some of the view modes, the ones that don’t work are Lit, Detail Lighting, Reflections, Light Complexity and all the Buffer Visualizations.

Same as cloudfactor, seemed to happen after duplicating a level and loading it up and as mktwo said it is fine after a restart.

Thanks for the information. I still have not been seeing this on my end. Could you reproduce it in a clean project and detail the exact steps you took to get this to occur?

Ok, really easy to replicate. New blank blueprint project, no starter content, desktop, max quality.

  1. Save the default map
  2. Duplicate it (drag to content folder and choose copy)
  3. load the duplicated map

I then can’t select the meshes as described before. to fix you don’t even need to reload the editor just loading the map again fixed it.

Edit: That was with 4.12.5, just tried in 4.13 preview 2 and I’m not getting the problem.

If the issue is not occurring in 4.13, it is likely that it was fixed along the way as part of another change. If you notice the issue crop up again in 4.13, feel free to respond to this thread and I’ll be glad to continue to investigate.

Have a great day!