Can't seem to get Datasmith to work consistently from C4d

I got it working once or twice but even have made new levels as well as new games and cannot seem to get Datasmith to import from C4d. I am on unreal 4.27 and tried on unreal 5 preview in hopes that this was fixed or updated. Does anyone have any suggestions or ideas?

Can we get more details on what is failing?
do you get no import at all? partial imports?
can you share the log files of the failed import

It works everytime in UE4.26 but never in 4.27.2

IN 4.27.2 I get no import at all, I see it go to 1 percent loading then disappears and my ram starts filling up then nothing happens, I’ve tried reinstalling engine for 4.27.2 and reverifying. I have also tried new levels, new game, restarting many times too.

I usually end up forcequitting application after 10-30 minutes. How do I access the log file of the failed import? Is there a recorded history of this event if I have to forcequit the application?

you can go in the folder of your project then looked into ./saved/logs/ and share the latest log file with us.
Does it do that with any C4D file? could you share your file with us?

twelvesevcendytwoer.log (110.8 KB)
a1274.log (117.8 KB)
Here are two logs, one for 4.27 and one for 5preview 2

I had my friend test on his UE5 and it worked fine for him with my files. Here is a C4d project in case you want to test also. Dropbox - 0881G.c4d - Simplify your life

That is strange: I do not see much in the log files.
the twelvesevcendytower.log shows 0881H.c4d is being loaded but the log stops just after that and before static mesh are created.
the other one does not show any c4d import.

I successfully loaded on my 4.27.2, around 2 minutes to import the file you shared with me.

maybe @Antoine_Guillo has some ideas?

Weird, I have no issues importing that file you posted in 4.27 nor 5.0p2.

It takes 10s to import, which is well within expectations…

My friend tried on his computer and it worked just fine as well. What could be different on my computer? I have tried new games, reverifying engines as well as uninstall/reinstalling too.

It sounds you tried everything that we can think of.
And as there is nothing in your log and we cannot reproduce that is hard to continue troubleshooting.

For now I guess I can continue to import into 4.26 and migrate project once imported into UE4.27 or UE5prev 2.

That works perfect every time lol few extra steps tho

Would crash logs show anything if I force quit?

Upon further testing in UE5 preview 2 and unreal 4.27 when data smith importing occurs often, ram will go up to 110gb in use of my total 128gb. It will stay there for about 20 minutes then creep back down to 30gb and never go anywhere after that. Memory leak?

Wish I knew how to troubleshoot what this issue could be. Still using the workaround of importing into 4.26 then migrating project.

This leads me to guess that some other part of the architecture that data smith runs on is broken on my machine. Does anyone know what dependencies data smith relies on that I could try to reinstall or possibly update?

With the new release of the official V5 it all works perfectly now!

Update…It always works great the first time I import a scene from C4d. If I delete that folder and then try to reimport the updated scene it always hangs. Only fix for this I have found is restarting the computer then it works again. I am guessing there is some kind of Datasmith or UE cache that is cleared on restart