Can't Save level Untitled (Editor) all 4.17 projects

Not sure if this is a bug or I I did something wrong.

My game says my level is Untitled in the world outliner. when I go to save it asks me to name it so I do and save however the name in the outliner doesn’t change and when I go to save again it still says I need to name my level.

Every time I save I get a new file in my content browser.

How do I get rid of this Untitled level?

Also I tried a different project I was working on in 4.17 and I know I had named that level before and it does the same thing when I try to save. Asks me to name it and in outliner it calls the level Untitled.

When I open a 4.16 project it doesn’t have this problem.

I left one of my 4.17 projects open last night and windows updated restarting my computer. could it have corrupted something?

Any help would be apreciated.

Ok I fixed it.

I had to change the default level and starting level in project settings then close the project (It made me save another level when I closed). When I re opened the level it was fine. I then had to delete all the levels I’d saved trying to get it to work earlier.

I had to do this on all my 4.17 projects that were working fine yesterday saving correctly and whatnot.

Not sure what happened but I figured I’d leave this up in case anyone else has this happen.