Download

Cant reproduce shading as seen in Marmoset.

Dear Unrealers,

I am in the middle of an application process which requires an art test. The Test demands a furniture-advertising demo in UE4.
Althoug i have no prior experience outside of Unity i decided to give it a shot and worked by an Max -> Xnormal -> Marmoset Pipeline with Marmoset for Realtime-QC.

As it turns out i have not been abled to reproduce the rather decent Results of Marmoset in UE4. (fig. 2)
The forum search turned up the possibility of a TB-Space issue, since UE4 is described to have switched to this tangent-basis space.
But checking “compute binormal in the pixel shader” only produced a total mess (fig.1)

Things i hace also tried to no avail is flipping green channel and generally playing with the import / compute normals&tangents settings.

Can anyone imagine why UE wont accept my normal maps as they are?

Can you please post your Material setup, Normal Textures as seen in UE4 and import settings for your meshes. Without seeing more it is going to be hard to track down exactly what your problem is.

Make sure you are exporting with proper settings in the FBX exporter: https://docs.unrealengine.com/latest/INT/Engine/Content/FBX/StaticMeshes/index.html#exportmesh

And if you are having normal problems that are truly unexplained, go into the static mesh window for the chair and turn off MikkTspace tangents.

After a bit more research i think i have found the culprit.

As described in the very helpful Thread, you do not only need to check “compute binormal in the pixel sahder”, but as well avoid exporting any tangents in the fbx itself.

The rest seems to bee caused by crappy UVs. The five stilts are all overlapping with one of them in the 0-1 UV-Canvas, wile the rest are on the exact same position, just shifted to the right
by one canvas lenght, so one island is baked and projected on the other five. Didnt know that this was a DONT.

d6310d67bdba7177bd6841e72bce9c9a09870630.jpeg

795d75f7ae723ed94c830ac99bebc2e75520a404.jpeg

Also don’t forget that Marmoset is Y-up, whereas UE4 is Z-up. It might be the problem.

While this might not fix all of your issues there are a few things that you have setup incorrectly. First, Roughness should be using a scalarinput and not a vector. The same also goes for Metallic as well. I am not sure what you are doing with the Texture coordinate for your Normal map but I would remove it as it is most likely not helping you out.