Can't package because project doesn't recognize Visual Studio; other projects do

EDIT: It turns out that this was because I disabled the plugin “Visual Studio Integration.” Protip: that’s generally a bad idea when you need Visual Studio.

Since updating to 4.19, I have been unable to package my project because it does not recognize that I have Visual Studio installed, both 2015 and 2017 with proper C++ components. I do not use C++, but I have a plugin that requires it. The weird part (at least from my perspective) is that this happens on multiple computers when I copy the project over, but it does not apply to other projects made on the same computer(s).

I get the feeling that some setting is messed up somewhere and it doesn’t even know that it’s looking for Visual Studio, because when I open the file menu, I see this as part of the menu:


A healthy project file shows this:


If you contrast the second-to-last option, you will see that the unhealthy menu shows the word “None” where the healthy one shows “Visual Studio.”

When I go to actually package the project (for Windows 64-bit,) I get the “Installing Visual Studio” message that typically displays when other people have this type of issue computer-wide:


I don’t really know what to make of this. I did some checking through various config files, comparing them with a healthy project, but found nothing conclusive (though I am not experienced.) I’m looking for ideas at this point, and am willing to share any files that are necessary (within reason, of course.) While this isn’t impacting my development process, it does prevent me from releasing updates.

Try to go into directory of your project and right click yourprjectname.uproject and click generate visual studio files also take a look if you have yourprjectname.sln in your project’s directory.

When I clicked “Generate Visual Studio project files,” it brought up an error box saying “This project does not have any source code. You need to add C++ source files to the project from the Editor before you can generate project files.” As I said earlier, I do not use C++, but a certain plugin (that I have already tried disabling) requires it. Also, there is no .sln file in the entire directory. Thanks for the ideas.

I have added new class in editor and .sln was genereted automatically. This should solve your problem. You can delete this class later. Let me know if it’s what you searched for.

I tried creating a C++ class, but I just got this:

I tried installing Visual Studio from this link, but it said I already had it, and just updated the existing install. I tried restarting both the engine and the computer, but there was no change, and the error message remained.

What is the plugin that you installed(this one that you mentioned above)?
Can you try to change compiler?

The plugin is Rama’s Victory Plugin. I selected the compiler version option, and it recognized Visual Stuido (both 2015 and 2017) as options. A computer that has neither installed still recognizes these options. Selecting these options did not change any of the issues, even after restarting the engine (for 2017; I did not restart for 2015.)

try disabling the plugin and then changing the option, restart and try.

Still nothing.

Did you made changes to any config files?

I have adjusted config from withing the editor, though I can’t say specifically what given that I’ve been working on this project for years, but I can’t recall directly editing the files, and if I did, I knew what I was doing, because it wouldn’t be a good idea to do so otherwise. These edits have happpened before the issue started when I updated to 4.19.

Here’s a copy of my config if you need it for reference. (Click the space to the left of the opening parenthesis. Or if not, just click here.)

I have created new project and used this config and everything seems to work fine. Last thing I can advise is to check if you have everything set correctly Setting Up Visual Studio for Unreal Engine | Unreal Engine Documentation,

Thanks. You gave me the idea to copy files into a healthy project to see what goes wrong. It was by this tactic that I was able to isolate the problem to the .uproject file, from which I further isolated it to the fact that the plugin “Visual Studio Integration” was disabled. I hadn’t even realized that I had done that; it must have been when I was cleaning up my plugin list upon updating to 4.19. Unfortunately, that event slipped my mind when typing up the question, so I apologize for the inconvenience. Re-enabling the plugin has cured all of the symptoms. I will try to remember not to disable it again. Thanks again for your help; I’m going to mark your answer as correct because you gave me the idea to copy files over.

I made a change and deleted my change and now I’m receiving this problem. Is this why? How can I restore the source code?