Can't open newly created C++ project

Having used UE4 for several years in BP mode, i would like to try learning C++ also.
However, when trying to create a brand new project, i get this error and everythings goes to a halt.
I have tried opening with Visual Studio, and building the project in there, no change.
I have tried right clicking on the MyProject.uproject file and selecting generate Visual Studio project files.

I have tried uninstalling Visual Studio and installing again, with different settings, incl. .Net desktop development, Game Development with C++, Win 10 SDK, Unreal Launcher, Universal Windows Platfrom Development. It’s the 2017 Community version i am using.

When creating the project i receive this error, and cannot open it in UE.

If i try to build, and open again, i get this error.


How can i get started with Visual Studio, or is it not worth it due to all this hassle?

This sounds exactly like the same issue:

The recommended solution is to do a cleanup of previous versions using Releases · microsoft/VisualStudioUninstaller · GitHub then repair VS2017 CE.

Thank you! Seemed to vork.
First uninstalled everything manually, then ran the program the link lead to, and then reinstalled VS through the UE4 installer when opening a C++ project.

Great, happy to hear it worked! :slight_smile: