Can't launch on device iOS

I just finished to rebuild UE4Editor on mac and started to launch on device with simple level (blue print fps)
But got error, how could I fix it? It seem to be missing UE4Game file

Howdy Batigol,

Thank you for posting this issue. I am going to need a bit more information from you before i being digging into this issue. Would you be able to provide a full build log to this post? Also, Have you tested this issue on a newer version of UE4? There have been many Mac improvements since then. Also, Could you attached the specs of your Mac to see what you are currently running?

Any additional information would be greatly appreciated.

Thanks and have a great day!

I’m working on 4.4.3. Haven’t tried with 4.6 yet
Here’s the full log
link text

Hey Batigol,

If you could, would you be able to test this issue on the 4.6.1 version of UE4 to see if this issue is still occurring for you? I have been able to launch on and package and deploy from a Mac to an iOS device via the 4.6.1 build. There have been many mobile fixes implemented since 4.4.3. It may be possible that this issue has been resolved in a newer build.

If the issue has not been resolved, please be sure to provide an updated build log so that I may be able to compare them to the previous log that you have provided.

Thanks and have a great day!

Howdy Batigol,

I just wanted to check in with you and see if this error has been resolved since upgrading to a newer version of UE4. Please be sure to let me know so that i may help out further with this reported issue.

Also, If the issue has not been resolved, could you attach the information asked for in the above post so that i may be able to further investigate.

Thanks and have a great day!

just a bit busy after 4 days holiday, I will try to test and get back to you soon

Just tried with 4.6.1, the first time take almost 1h20minutes and the second time is around 1 minutes but got same error
link text

By the way, how to build the release of UE4Editor for mac, I just build with default setting and the result is debug(UE4Editor Mac Debug)
We don’t have experience with native xcode, just build with Unity3D :slight_smile:

To build a release editor, press the Cmd key, Shift key, and < key simultaneously. That will bring up the scheme editor for the currently selected scheme (make sure UE4Editor is the selected scheme). In the Info tab, you can change the Build Configuration from Debug to Release.

For your other, since it looks like you are building from source, you will need to build the UE4Game for IOS. To do that, in the same project that you use to build the editor, you will find a scheme called UE4Game. Select that scheme and select IOS as the target platform (right next to the scheme selector) and then build that. You will then have a UE4Game-IOS-Debug and if you do the same thing you did for the UE4Editor scheme (above), but for UE4Game, you can build the release version it is looking for.


I just follow your instruction but can’t find the release option in Build Configuration. Is it the Shipping?

About UE4Game for iOS, I just select and build but got a popup error. Could you take a look at it and give me advice?

I haven’t run through the particular dialog you have there (normally build from XCode) but if you are trying to run on iPhone then you likely want to change the “Destination” option at top to iPhone rather than your MAC.

Assume you’ve setup your provisioning and signing certificate in the iOS section of Project Settings?

any one help?

I don’t think we have to chose destination to iPhone, because this project is building UE4Editor for MAC then using that version to build apps to iphone not building directly apps to iphone

could you take a look at my log and teach me know how to fix it?

Howdy Batigol,

Sorry about the lack of response on this issue. Just wanted to check in with you and see if this issue is still occurring for you. Please be sure to let me know so that I may be able to further assist.

Thanks and have a great day!

Hi Batigol,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

Hi all, we still stucked on this issue at least to last week. We are on long Lunar New Year holiday now. I will back to work next week. If possible, please help us take a look at our log in this link 25768-logan06.txt (2.23 MB) (UE4.6.1)

Sorry, I misspoke. I meant build the Development version of the editor. You will also need to build the Development version of UE4Game for IOS as Launch On does not build the application and that is what is missing in your Launch On log.


Hi psauer, how to build the Development version of UE4Game for IOS as Launch On?

Hey Batigol -

All you need to do is Build IOS for development, once you’ve done that, you can then use launch on to deploy. There are 2 ways you can build it.

From Xcode
Select the ProjectName - IOS > iOS Device
Edit the Scheme (shift+cmd+,) and set the Build Configuration to Development

From Project Launcher

  1. Create a custom Profile
  2. Select Edit (Wrench and Screwdriver)
  3. Set Cook, Package and Deploy to “Do Not *”
  4. Enable Build Set Build Configuration to Development
  5. Select IOS
  6. Select Back then click Launch (Controller and Display)

Once you’ve done either one of these look ing */Engine/Binaries/IOS/ for the UE4Game.ipa