Download

Can't get Vive to work with UE4

Is there a “do all of this initially for Vive to work with UE4” checklist that I’m missing somewhere? I’ve tried everything and can’t get it to work. Every time I hit VR preview it just uses the orientation data from the headset but the screen seems to be a strange split view of the normal 2d standalone window. Also, SteamVR is constantly yelling at me about the compositor not being full screen.

I use my DK2 with UE4 all the time and never have problems.

FYI – I’m able to get the balloon blow-up game that you launch directly from SteamVR to work, so it’s not a faulty HMD or anything like that.

With the newest Oculus driver updates a bug was introduced that stopped HMD’s running SteamVR to properly connect with UE4. For now disable the Oculus HMD plugin in your UE4 project and you should now be able to connect with your HMD and SteamVR again.

Hi Sam, that didn’t work. When I hit VR Preview it still shows the split 2D standalone window in the headset. I can see the chaperone bounds in 3D when I look through it though.

Hey Jeffym85,

Did you try and run Showdown? If so did that work at all? Also can you post an picture of what you are seeing on your monitor when you press the VR Preview button. Also have you read up on the SteamVR official docs? You can find them using the following link.

Let me know if any of this helps or gets you further than before and if not I will see what else I can do to help.

I was able to get it to work. I did a fresh install of steam VR and changed USB ports (not sure which one did the trick). Thanks!