Download

Can't get teleportation to work

I have a project I’m trying to get teleportation to work. I have navmesh showing green and that seems correct. I have my MotionControllerPawn set up in my scene right on the floor. I have a box brush set as the floor. Ive also tried a normal cube as the floor and everything has the correct collision. When I go into VR, everything seems right, except I cannot get any arrow or arc to show to teleport. I cant move at all. What am I missing here? Tutorials I watch dont seem to help, it just seems to work for them no issues. Using 4.25.
Thanks

Are you using the default Blueprint VR template?
If so do you see the short stump arc or nothing at all?
do other controller behaviours work?

a few things that come to mind giving your issue:

  • Is the controller button correctly set up in the input settings?
    If you are using steam vr: try regenerating the input bindings in the steamvr plugin dropdown menu.

I just imported the standard VR project files to my current scene. I only see my hands, no arc or short stump. Just my hands, and they dont move at all when I press any buttons. In the MotionControllerPawn, do I need to check anything specific for it to work? I have Auto Possess Player set to “Player 0”. I tried ticking the “Use Controller Rotation” boxes, but that didnt do anything. I also tried setting under Input - Auto Receive Input to Player 0, but that didnt do anything either. Are there other Input Settings I need to change somewhere?

https://forums.unrealengine.com/core/image/gif;base64

Yes. In your project settings you should setup the controller bindings. That should look like this.

782e935e001f87d062ac8f80c3234acf3021cac2.png](filedata/fetch?id=1824088&d=1603217810)
https://forums.unrealengine.com/core/image/gif;base64

If there is nothing there your controller input will not trigger the events in the VR template’s blueprints. (if you start from the template this is automatically set)

You can add them manually or import them in the top right corner. The input settings for the VR Template are stored in this location:
C:\Program Files\Epic Games\UE_4.25\Templates\TP_VirtualRealityBP\Config\DefaultInput.ini

(for some reason I personally fail to import it directly from there, but you can try and copy it’s contents and create an new “.ini” file and copy them in there to import them)

Interesting…I cant seem to import like you said…and creating a new .ini file doesnt import either. Gonna try to look more into this.

a method that works for me: create a new project using the vr template, and choose export there, then import that .ini file into your existing project.

I opened a VR test project I have after quite some time. It seems the controller binding names have changed. Took a while to figure this out since there is no indication why previously working code would no longer teleport.

I manually updated the input binding in the engine. The new names are very readable and it hardly takes a few minutes.

I got this working, thanks!

I now need to know how to manually use one of the thumbsticks to adjust height only while in game. Not sure how to go about this…

You will have to create an input event like the ones you bound, and have your logic fire upon that event.

if you’re unfamiliar with blueprinting it might be handy to get into some tutorials first.