Can't get Oculus to work in Unreal

I’m very confused because it doesn’t seem like I can find other people who had my problem. I installed the oculus and I tested it out. When I go into Unreal 4.12, the “Preview in VR”(when I click the down arrow next to the play button) is greyed out and I can’t click it. I also went into the plugins and there is no section for Head Mount Display which I saw someone do in a tutorial video. I read that Unreal is suppose to automatically detect the headset when it’s plugged in. Is there something I’m missing? An SDK I have to download, maybe? I also went to and went under download, other downloads, engine integration, and there was a section for Unreal Engine 4 Integration. I clicked the Details button next to it and it took me to a page with a Download button that I can click once I accept the terms and conditions:

But when I click it, it just takes me to a documentation page:

Can someone please help me. I’ve been trying to figure this out and watched several videos and read several tutorials for setting up, but I have to be missing something. The only thing I can think of is the tutorials are somewhat older when the Oculus website was older and Unreal was in an older version such as 4.4 and it seems there used to be an SDK you had to download. I can’t find that and I’m assuming it’s because the new Oculus Installer and Unreal Engine versions already have everything included.

Ok, update, I looked at all the plugins and found the Oculus plugings. I clicked the HMD plugin restarted and now the “Preview in VR” button is clickable, but it opens a window with the VR view, but I don’t see it in my headset. All I see is the Oculus Home screen on my HMD. Also, when I click launch, after a while it says launch failed, but I don’t know how that’s possible since it is a new FPS projected I opened and I didn’t do any editing.

PackagingResults:Error: Error Launch failed! Missing UE4Game binary.
You may have to build the UE4 project with your IDE. Alternatively, build using UnrealBuildTool with the commandline:
UE4Game <Platform> <Configuration>

Also, When I click the VR button (to the left of the Play button and has the icon of a VR headset) unreal either freezes or crashes.

Might sound stupid but did you allow your Oculus Rift (under Oculus Home settings) to run on Unknown sources (or third party application)? It wont work if you dont do that first

Thank you for responding. Yes, I have put it on to run Unknown sources.

First i would try and use the binary version (that you can download from the launcher). UE4 has built in support for oculus, and is the easiest to get working (Limit the number of things that could go wrong). You don’t have to download anything from oculus (usually they are quicker to update their SDK, but Epic is pretty good about updating to latest SDK for each release). Try downloading 4.12.5 (or 4.13 preview 1: which has Oculus 1.5 sdk, Preview 2 should have 1.6 if I remember correctly) from the launcher and see if it works there.

Thanks, I currently use 4.12.5, i’ll try 4.13