Download

Can't get GI on?

Hello,
this is my first time posting and I am new to Unreal 4. So far having fun with the editor!
I’ve one of the most noob-ish of questions though but I just can’t seem to figure this out.
I’ve built a test scene following the quick start guide here:
https://docs.unrealengine.com/latest/INT/Engine/QuickStart/5/index.html

My lighting looks nothing like in the guide, specifically, I just dont seem to get any GI bouncing around when building. (lighting is set to Production). You can see in the attached image how all my shadows are pure black.
My directional light seems to contribute to the lightmass, I’ve placed a LightMassImportanceVolume around my BSP boxes… what’s going on?

Again… sorry for the noobishness but I’m already at a loss…
Thanks for helping!

I should add, the skylight in the screenshot is turned off on purpose to figure out why my directional light is not causing any GI. I believe this said skylight is creating GI fine. I’d love to figure out why the directional light is not.

Did you rebuild your lights? (the big BUILD-Button in editor)
Because GI is not realtime.

Try to change your directional light from Stationary to Static

Hey guys,
Thanks for your replies, I appreciate the help.
Here’s a bunch of screenshots. First to show that my lighting build settings is set to Production and yes I press build everytime I try something new on the lighting front.
I’ve tried setting the Directional Light to Static as you mentionned DarthViper, the result, in the second image, is still pitch black.
I tried with different lights: PointLight and Spot Light. Both also return pitch black shadows with no indication of GI?

Wierd thing is, as the last image shows, a skylight seems (at least to me) to be casting GI no problem. So what’s going on?
I see four possible explanations:

1- Everything is working as intended, Directional/Point/Spot lights don’t cast any GI and I’m too nOOb to know that.
2- I need to enable a check box somewhere to turn GI propagation on for Directional/Point/Spot lights as that is not turned on by default. (All light values in the screenshots are at default.)
3- Something else of my very basic setup is wrong. (I do have a lightmassimportancevolume around the BSP boxes… is there something else I’m missing?)
4- Engine is bugged. (Running 4.6.1)

You guys have more experience than me… can we rule out possibility 1 and 2?
That would mean my setup is wrong or the engine is bugged. In regards to no. 3, what could I possibly be missing?
What steps could I take to debug/troubleshoot this issue?

Thanks again!

It looks very much like it’s using dynamic shadows, the meshes are BSP right?

The meshes are BSP yes. How would I check if my shadows are dynamic? Would that be the issue?

I’ll be testing this setup in 4.5.0 and 4.7 preview 1 to see if the problem is version related.

You could go to marketplace and download “Xoio Berlin Flat” or “Lightroom”. Both are free and have GI. Then you could rebuild them and look if everything works.