Download

can't focus on translucent material

DoF and translucent materials are not working ok together it seems. Is there some setting that needs to be enabled?

In your translucent material, try unchecking the “Render After DoF” checkbox. It’s under the advanced Translucency section.

this setting doesnt seem do anything. The glass part is only ever in focus if something non translucent is in focus behind it.

Indeed, that’s probably another issue.
When using DoF I usually set focus distance in blueprints by doing LineTraces from camera (similar solution explained here). Maybe something like that will help you. If the trace hits the glass surface, it will work. But for that you need to have quite accurate collision meshes (or set the meshes to per-poly collision).

Not really ideal, but one option: 1.6 - Separate Translucency | Unreal Engine Documentation

Well someone correct me if I’m wrong but this option is there only on mobile and on desktop it is the render after dof option. Which like I said doesn’t do anything and it’s either broken or ignored or requires some specific configuration of other settings to work properly.

That said, it looks like a pretty bad solution, maybe in a specific case for a specific camera shot it could do the job, I don’t know cause it doesn’t work.

Another partial solution I found is using single layer water shading model. that one can be focused on cause it’s opaque. However everything behind the glass is then also in focus no matter how distant and you can’t see liquid in glass or other glass behind it.

Raytracing or not, it seems that making convincing looking glass in unreal is only possible for thin panels (windows, table tops etc). Definitely not stacks of glasses, liquid in glass etc…

It’s possible, it just isn’t easy or convenient.

Ryan Brucks started a breakdown of this back in June but hasn’t followed up on it with the second part. Don’t think this would address your particular problem though.