Download

cant fix this lighting with 24h time

I basically want the light to be brighter indoor but without any pointlight or anything else. Also why is the light going through my walls, they are seperate models when the were 1 model the light didnt went trough.

Sylight is already added

pls anyone help i read forums but they didnt work for me :frowning:

First determine which light source is causing your light to go through the walls, then make sure that ‘Cast Shadow’ is turned on.

Directional light is going trough and cast shadows is turned on i disabled it and enabled it but nothing drastically happens
Unbenannt.png

I want to make the light dynamic day cycle so everything works and no baked lighting everything realtime. https://youtu.be/AphIofwFnUU

here is another example i managed to fix but its very big and on thin walls it doesnt work .
s.png

Have you tried setting your wall material to double sided? The default movable light setup is not the most accurate, I would recommend adjusting some of the settings https://wiki.unrealengine.com/LightingTroubleshootingGuide#Adjusting_Cascades_for_better_Quality:

Also sure your editor settings are turned all the way up

ScaleR_ViewQual.png

For the light going through the walls - do you have a sphere reflection capture placed somewhere outside? If you have, try moving it like that the sphere bounding is out from the room, just to not intersect the floor. If this fixes the problem better use the box reflection capture instead the spherical one. About the light are you sure that the light is set on movable? Could you take screenshots of everything - Material, lights and show us the 3D mesh you are using for the room so we can troubleshoot the problem. :slight_smile:

Hi thanks for the help guys, the problem was the quality settings were on middle, then i changed them to high and voila IT WORKS.
Does anyone know why this happens when its medium settings?
hu.png

AHHH FINALLY I CAN WORk but there is one problem why is it getting so dark when i build thelighting inside? its pitch black

The reason why medium settings can cause these kinds of issues is because the light & shadow approximation is much less accurate to save on performance

You can either increase your skylight intensity or I recommend that you increase your exposure settings which would make your dark areas brighter.

yeh this happens some times with me too. Now I know why. Thanks guys. Playonce I’m happy you solved your problem.

I have another issue the light and ao kind of doesnt use the autosmooth from my mesh. My mesh is autosmoothed but the shadows or AO kind of dont use it.
Unbenannt.png