Download

Can't find what exactly causing this red/yellowish blurry outline/DoF

Here are two screens for comparisson: http://imgur.com/a/6CNzW

Most noticiable part of this blurry thing is around AK-47 rifle. My eyes/vision gets very tired when playing like that, so i turn post-processing down to very low, but then there is no ambient occlusion and anti-alising gets a bit worse.

In Scalability.ini i have following:

[PostProcessQuality@4]
r.MotionBlurQuality=0
r.BlurGBuffer=0
r.AmbientOcclusionLevels=4
r.AmbientOcclusionRadiusScale=1.0
r.DepthOfFieldQuality=0
r.RenderTargetPoolMin=400
r.LensFlareQuality=0
r.SceneColorFringe.Max=0
r.SceneColorFringeQuality=0
r.EyeAdaptationQuality=2
r.BloomQuality=0
r.FastBlurThreshold=15
r.Upscale.Quality=0
r.TonemapperQuality=1
r.Tonemapper.GrainQuantization=1
r.Upscale.Softness=0
r.PostProcessAAQuality=4

I added all those lines myself, originally file was blank. I thought that setting bloom, DoF and blur to 0 would do the trick and i will get good Ambient occlusion with good anti-aliasing without any blurry stuff. Bur for some reason these cvars don’t take any affect.

Am i doing something completely wrong or it’s just not these exact options and i should change some other cvar?

Did you figure it out? I think I saw a post on reddit. It’s the chromatic aberration.

Yep, i asked same question on reddit and some good person replied that it might be scene fringe effect, and indeed it is.
Here is info on it: https://docs.unrealengine.com/latest/INT/Engine/Rendering/PostProcessEffects/SceneFringe/
Also, corresponding cvars are:
r.SceneColorFringe.Max=0
r.SceneColorFringeQuality=0

Zeroes disable this effect.

ps in my case part of the problem also lied in that game doesn’t want to register epic sacalability options @4, but registers changes at [PostProcessQuality@3]. Don’t know why though, maybe some inherent bug of devs, but using 3 for now