Can't find android device

Hi. I’ve been battling with this problem for 5/6 days now. I have found and read various threads and webpages on what third party apps to install and how to setup UnReal. I have succeeded with some but still cannot find my android device in the launch list.

Steps I have completed:-

  1. Visual Studio 2019 (installed)
  2. VS 2019 Workload
  • C++ Profiling
  • Windows 10 SDK
  • Intellicode
  • UnReal Engine Installer
  • ANdroid IDE forUnReal
  1. CodeWorks -1R8-windows-b181 (Run)
  • NVidia Tegra (Keeps complaining about Visual Studio Dependency - not installed)
  • USB Drive (NVidia) -installed
  • USB Driver Shield (installed)
  • Documentation 1R7 (installed)
  • Android Toolchain (installed)
  • Android NDK (installed)
  • Java SDK (installed)
  • Apache ANT (installed)
  • Gradel (installed)
  • USB Driver (installed)
  • Android SDK (base, platform & build tools) -installed
  • Android 8 API 26 (installed)
  1. UnReal
  • I have activated the Android licenses as required
  • Am running UnReal Studio (blank project) so as to important Datasmith file from 3rd party program
  1. My phone has got “Developer Mode” enabled.
  2. I have installed Samsung drivers on my PC.

It’s just crazy how much one has to do, just to attempt AR/VR. Surely there must be simpler way?! Anyway, if anyone can help me with my Tegra installation (how to clear the Visual Studio dependency issue) IR has any other helpful tips on how I can get UnReal to recognise my android device, I would really appreciate it.

EDIT:- Error when installing Tegra - “Installing Nsight Tegra, Visual Studio Edition 3.5 failed. Return Code: -1 com.nvidia.nvtools.pentak component is not defined!”

I had this problem (not the exact same error, but similar for different packages) but I’m pretty sure it was because my system was setup up to install NDK in a non-default location. Installing to the default location fixed it.

Thanks. Just managed to resolve it this morning. Not entirely sure what I did. I know that I forgot to activate “USB debuggin mode” on my device. That wasn’t the only thin because UnReal still didn’t detect it after I changed that. There was something about using the “Device Manager” inside UnReal. If you go to “Launch Options” and the device isn’t listed, then go down to “Device Manager”. I found my device in there and selected it. When I went back to Launch Option, then my device was listed.

Now to figure out why launching fails to my device. These technologies really aren’t for the faint of heart - always another problem to fix.