Can't expose parameter to MI


In graphs like these when I convert the node responsible for tiling to a parameter it doesn’t show up in the material instance. Is there there a workaround?

Actually any parameter node that goes towards the grass output node and “not the material output” does not show up in the material instance.

Use [Scalar parameter] not [Constant]

Unfortunately doesn’t work. I ran into this exact same problem yesterday myself.

I think it’s because Grass Maps are baked, and changing a MI parameter would require re-baking grass maps, so it’s not something that can be changed at runtime (which is the ultimate purpose of MI’s).

That image is taken from the Grass tool documentation. My own setup is scalar parameter but doesn’t get exposed to the material instance.

Still seeking an answer.

Have you tried a Material Parameter Collection with a property of the appropriate value? I’ve not tried it and I’m not in front of my UE machine to test it out.