Can't Download [Patch Data Error]

Some minutes downloading and… this happen:

Also the download meter is not too good, it don’t have a % count, just talk if you download or not the last 1GB ( what with my connection take ages and is hard to keep tracking ) but i think it’s a feature request not a bug report isn’t? xD

Error in:

Windows 7 SP1 , Intel i5, Nvidia GTX560TI and a 1Mb/s ( 178kb/s downloading ) ADSL connection.

More information:
I can download nicely some content in marketplace (and i can see a % count now for it ). Mobile Template and Tappy Chicken download fine. The others i get the same error than the editor.

Hi vBalbio,

Sorry for the inconvenience. A basic question, but have to tried closing and re-opening the Launcher? Sometimes this can help.

Please let us know if the issue is still occurring for you.

Yup i try it and restart the pc too, reinstall the launcher, install in another folder, start as administrator… i tried everything that i could think about it, i’m still getting the same problem =/

Hi vBalbio,

Sorry to hear you are having issues. That error message is associated with a piece of data needed being unable to download after several tries.

Each time you attempt to install, it should resume from the previous point it got to. Have you noticed if you get any further with each try? The marketplace items you mention are smaller, so that could be why they work easier.

I would like to help more, but need some further info from you if that is ok.

Open up:
“C:\Program Files\Unreal Engine\Launcher\Engine\Programs\NoRedist\UnrealEngineLauncher\Config\DefaultEngine.ini”

And add the following two lines to the very end of the file:



After running again a few times to try and install, could you then go to:

Replacing User.Name with your windows login name, and attach a zip of the log files you find in there. There might be a few :slight_smile:



Hi Swiffy. Thanks for the reply. I unstall, cleanup with Ccleaner and install it again in default directory. That’s what i got in Log:

Hope you can help me, two days without Unreal =/

Thanks for the log. It looks like you are having trouble connecting to our cloud for patch data. I need a more detailed log to see why.

Could you make the DefaultEngine.ini changes that I mention above, and then run the Unreal Engine shortcut on your desktop to try downloading some more times.

When you get the patch data error. Close the Unreal Engine program and then zip up the logs in the Log folder i mention above. Upload that zip file here.

Thanks for your patience with this.

No problem, early adopters have this kind of issues. Hope fixing it to me make UE4 more stable for any user. Actually i forget to enable Loghhtp = Log in the last log posted above. Here is the zip as you asked


I tried to install and download with my laptop (windows 8.1, i5, 6GB, NV 630M) and i get exactly the same error.

Hi again. Thanks, that was just what I wanted. I can see the types of error you are getting now indicate that the cloud server is not responding to the patch data requests. I will now be able to consult with colleagues to investigate how we can help you :slight_smile:

Thank you Swiffy. I will be waiting some workaround to handle this

Hey, could you try clicking this link and let us know if you successfully download the file:-

You should get a 1008KB file.

I downloaded it without any problem

I tried others from log and i downloaded it directly without problem. such as:

It let me think about firewall ports and permissions, i enable all and turn off the antivirus too. Nothing works. And in my notebook i get the same problem. It can be a router problem? but i have no problems with any other application so…

I was just thinking about firewalls. Some routers have firewalls in too. Do you have a setup where you’re able to trying plugging your modem directly into your PC to bypass a router? I imagine with ADSL it’s probably a single box though

Actually i have cause i have a Wireless bridge and a ADSL Modem separately and i just did it now. No results. I tried too disable the firewall in Router and not work too. Looks like just the Launcher app can’t download some crunck files. Remember that i can download some marketplace content without problem too. it keeps in 0% for the editor e for more big marketplace content like “Strategy Game”

I’m thinking something about the Timout in launcher. Maybe the timout condition from the requests to return a "no response"is too fast for mid bandwidth connection (200kb/s downloading…) with high latency (200 ping for EU ) as my.

I’m from Brazil. Maybe he is trying to download but the delay for a response is too high so it give up the package and send a “no response” message. That’s my think about it cause when i tried to download by browser the crunck file, it don’t show up in Download Tab until it is finished and take sometime. As the Launcher are trying to download many crunch in the same time i think the delay for a response is much high and cause the timeout condition it give up the package. It’s make sense or is just a crazy idea?

Not crazy idea :). The timeout is 30 seconds for any response. Which includes even just the first few bytes. We have a suggestion that may test the theory though. Could you open up a command prompt and run the following command:-

ping -n 600 > c:\pingtest.txt

That will run a ping to our cloud server for 10 minutes outputting the results to a text file on C:\ that you could then send back to us.

My colleague noticed that the content example also timed out one time but succeeded another so maybe you have a bit of a spotty connection that we could try handle better

that’s what i got