Can't download engine through Epic Launcher

Okay, so I searched through the settings of my router and found the below. Shocked that there were Firewall settings on, I disabled both of them and started up the Unreal launcher. The Launcher updated itself (2.4.2 I believe) and then after entering my details and waiting, it signed me into the laucher on the first attempt.

Excited I clicked the install button for the the Unreal Engine and… “Unable to download Unreal Engine. We’re unable to download this item right now. Please try again later.”
I should mention that this message came up the moment I clicked the install button, no delay.

I double checked that I’d turned the firewall settings off, tried again, but same result.

I’m a little weak when it comes to ports, could you give me a bit of guidance on how to check if ports are open, and which ones need to be open for the launcher?

EDIT: Suddenly able to log in to Epic Games launcher and launch from there, but cannot download any updates or marketplace content.

Hey Sofox,
Can you get me fresh logs with the new unable to download engine error? So I can take a look.

Sure, here it is.
I had to start Wireshark after I’d opened up the Launcher, if I started Wireshark before, it would give massive logs around 20MB big.
With the attached log, it’s of me with the launcher already open repeatedly trying to install the engine, sometimes removing it to try to install it again. In every case, the same error message comes up.
Anyway, here it is:

Hey all,

I am sorry support on this is taking so long. We are still working on the issue, but this is proving to be a complicated problem.

We really appreciate your patience on this.

Hey Sofox,

Thanks for providing a wireshark log, it would be really helpful to have a copy of your launcher logs with you attempting an engine download. Could you upload a fresh copy here please.

Hey VictorLewis,

Given you can now login could you upload some fresh logs. Please login and attempt to download an engine. Make sure you leave the launcher running for a good ten minutes so we have a decent log capture.

Hi Sofox & VictorLewis,

We haven’t heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you’re still experiencing this issue, please try the suggestion that Barnabas mentioned above. Then post back here with the requested info.



I have the answer.

It all lies in something called dual stack lite or “ds-lite” (yeah, like the handheld).

Long story short, UPC use ds-lite to deal with shortage of ip addresses. Users will get both an IPv6 and IPv4 address. The problems is that it leads to a single IPv4 address being shared among multiple users which can cause problems. While I was under ds-lite, I found some sites said my IP address was a normal IPv4 one, while sites like gave a long IPv6 one.
This made stuff like port forwarding impossible, so while trying to get port forwarding set up for a completely unrelated project, I researched the problem, found the above, and directly contacted UPC (now Virgin Media) representatives through They reset my connection back to just a single IPv4 connection, free of ds-lite, which is something they’ll do for customers who specifically ask them and are having connection problems brough through ds-lite.

So just now, I try the Unreal client, and yep, it’s starting to download.

So there’s your answer, if you have trouble getting the client under UPC (now Virgin Media), just phone them up or use to send them a message asking you to be removed from ds-lite and reverted back to just using an IPv4 address!

That’s good to know, thanks Sofox! Now I know why I was having trouble with port forwarding, I thought the IPv6 might been the problem there, but it didn’t occur to me that that could be also affecting the launcher

Hi Nathan,

Sofox has replied below mentioning that his ISP, UPC Ireland was using Dual Stack Lite to get around IPv4 address shortages and he was able to request that they remove that from his connection and now it’s working fine for him. Could you try asking your ISP to do the same for you please? Thanks