Can't download engine through Epic Launcher

Please, could you try running with -http=wininet on the cmdline now, we’re interested to see the verbose logs from this to see if it gives us different results to libcurl (the default), as the error from that library is too generic to pin point.

Thanks again


Hey, I’m also with UPC Ireland, and after following this thread it appears I have the exact same problem. Before -http=wininet I used to have the “Error: Connection to the Server Failed” only the first attempt at logging in and then an indefinite “Please Wait” message for the second try, but after -http=wininet “Erorr: Connection to the Server Failed” every time.

Here is the screenshot of the error message (same as above):


Thanks VictorLewis,

We’re sorry to hear you’re having similar troubles as the other users on this thread. Thankyou for the info/logs with wininet, I’ve passed this to our online team.


Hi chaps,

The only information we’re able to assertain from the logs is that the connection attempt timed out. For whatever reason you’re not recieving a response from the server, which could be due to firewall/router/ISP, etc.

The only way we’ll be able to work out more from this is if you do a packet capture locally, which you can probably do using Fiddler/Wireshark/Charles, etc. We’ll need to see all the TCP, UDP and ICMP packets tho. Keep -http=wininet on the cmdline too.



Hi everyone,

We haven’t heard back from anyone in a few days, so we are marking this post as Resolved for tracking purposes. If you’re still experiencing this issue, please try the suggestion that abrown mentioned above. Then post back here with the requested info.



Hey, I sent a message on Twitter to UPC but didn’t get a response. The link you posted doesn’t seem to load anything in browsers no matter which connection you’re on so I didn’t know how to usefully do that, and Wireshark takes a bit of time to set up so I wasn’t planning on doing that until I was ready.

If you mark this as resolved, it might send the wrong message, especially when trying to get UPC to look at this page.

Marked as unresolved.


Apologies on the URL, there was a slight typo, try:

Thanks, and please let us know if you manange to get anywhere with Wireshark :slight_smile:


Went to the link on my own computer ang got:

“errorCode” : “”,
“errorMessage” : “Authentication failed for /api/oauth/verify”,
“messageVars” : [ “/api/oauth/verify” ],
“numericErrorCode” : 1032,
“originatingService” : “account”,
“intent” : “prod”

Thanks Sofox, that’s what we expected too :confused:

Please let us know if you manage to run Wireshark.



Hey all, I tried again today and was able to log-in and download the engine successfully.
Not sure if it’s a change in a launcher update that has fixed it, or something from the ISP. (Aside from that, the only thing that has changed that I know of since I last tried is that I’ve upgraded to windows 10, which doesn’t seem relevant…)

@Sofox Have you had any luck?

Hey Mosel3y, Nope, I haven’t had luck. In fact, updating to the latest version I can’t even sign in, every attempt bring a: “Error connection to the server failed. Visit Launcher Troubleshooting.” (Incidentally, clicking the Troubleshooting link causes a browser to open with a page location that doesn’t point to anything)

Incidentally, I got around to doing a Wireshark capture of my problems which can be downloaded here. The capture starts before I open the client, and I make three attempts to login before I quit the program and then end the capture.

The moment when the error message poped up and the login failed seems to be around line 837 for my second attempt, and 1112 for my third attempt

Thanks guys,

Glad to hear it’s working for you Mosel3y, although we’re unsure why it would suddenly be working for you, perhaps the Windows 10 upgrade fixed something for you.

Sofox, thanks for the capture, I’ve forwarded this to our online team to look into. It’s also interesting that you mentioned the troubleshooting link not working for you either, this may be related.

I’ll get back to you when we have more information, thanks again.


I remember now I had been messing around with port forwarding on my router last week and may have changed other things inadvertently. I’ll have a look when I’m home and see if I can un-fix the issue temporarily.

@Sofox do you know what UPC modem/router you’ve got, is it the Technicolor TC7200?

Yep, that exact model.

I was experiencing exactly the same thing yeah. Although after I downloaded a launcher update it wouldn’t even go that far, just stuck in a loop trying to login the first time. I’ve since given up trying.

Sorry to hear that, blahusername.

Out of interest, when did you try this last? We fixed a bug in the Launcher on Friday which was causing the login issue you described if you didn’t have a specific port open for XMPP. Running the Launcher again will update to latest and hopefully fix this specific issue for you. If not, please could you provide debug logs?

Additionally, Mosel3y has had some success with getting his working now, which may have either been fixed by upgrading to Windows 10 or changing some port forwarding settings on the router (we’re waiting to hear back), we’re also looking into some packet capture Sofox provided us with to see if that can track down the route cause of the issue. Please see the bottom of this thread for more information.



I haven’t been able to recreate this issue anymore by changing any settings on my router, it seems to be permanently fixed for me, somehow

Ok, Mosel3y, thanks for letting us know. We’re going to dig through Sofox’s capture and see if that doesn’t shed any light on the issue.


Hey Sofox,

Any chance you have the firewall setting on the Router on? Maybe you could post a screenshot of your router firewall settings for us?

Also make sure that you have all the ports open that the Launcher Requires?