Can't download engine through Epic Launcher

I’ve been having this issue for a long time now, only on one computer.
I’m using the latest version of the Launcher.
I’ve read this page and tried the suggestions which hasn’t helped:

Firstly when I try log in, I often (but not always) get a message saying “Error! Did not get a response. Are you connected to the internet?”
I click OK, and try again, usually it works fine the second time and I can log in.

After this I click install under the engine version and I get the error message “Unable to download Unreal Engine. We’re unable to download this item right now. Please try again later.”
The button to add an engine version is greyed out and can’t be clicked. Though I appear to be logged in.

I’ve attached my DXdiag and launcher logs

[link text][1]

Hi Mosel3y,

This seems like this could have been something on our side. Could you try installing again and let me know what results you get?

Hi, thanks, but I just tried again and am getting the same result as before :confused:

EDIT: attached new log from latest attempt, if it helps: link text

Hi Mosel3y,

I’m looking through you log now, can you confirm that you are not behind a proxy?

-Max B.

Hi, I’m not behind a proxy, no. The test linked on the trouble shooting page also says I am not.

Hi Mosel3y,

I can see from your logs that you’re using the command line argument -http=wininet.

I assume you’ve tried this after having problems without it. Please can you let me have logs from running without that?

Also, can you tell me what you see in your browser if you go to


Hey, thanks everyone for all the help, I ran again without that, here are the logs link text

I clicked your link and I see:

“errorCode” : “”,
“errorMessage” : “Sorry the resource you were trying to find could not be found”,
“numericErrorCode” : 1004,
“originatingService” : “account”

Uh, sorry. AnswerHub has added dot to the end of my link. It should be

I’ve taken a look at your new log, thank you for that. It looks like there’s a timeout at some point and the system is retrying the connection. It seem like the launcher was closed during that retry. Sorry to be a pain, but can you rerun the launcher with debug logging and leave it for ten minutes or so before closing and send us the new log.

It says:

“app” : “account”,
“moduleName” : “Epic-Account-PublicService”,
“branch” : “Release”,
“buildDate” : “2015-04-30T02:23:37.597Z”,
“serverDate” : “2015-05-21T22:00:53.574Z”,
“build” : “91”,
“cln” : “2531218”,
“overridePropertiesVersion” : “$Revision: #83 $”,
“version” : “1.20”

I left the launcher open for about 20 minutes, and here’s the log link text

We’re seeing some oddness in your logs. Some of the server requests are going through but some aren’t. What does your network setup look like? Do you have a router between your modem and your LAN? If so, would it be possible for you to try connecting your PC directly to the modem and see if you see these same issues? We suspect there might be a firewall setting that could be throttling some of our server requests.

Hi, sorry for the delay. I’m connected directly to the modem already, My modem has firewall settings but I’ve disabled that and it makes no difference

OK, are you able to test temporarily on a different network (ideally a different ISP) so we can work out whether it’s a problem with your PC in general, or specifically with your network setup? I realise this may be difficult to arrange, but it could be helpful.
E.g. tethering through your cellphone if that’s included in your plan without additional costs, or using an alternative WiFi network you may have access to.

Just now I tried using my cellphone’s data and it worked… (obviously I can’t download the entire engine that way though). What could this mean?

Thanks for trying this. So, it means that it’s either the network settings on your machine for the original network you tried, or it’s a network configuration or ISP problem.
I’m going to talk to a few more people here and see if I can come up with some suggestions. The way that just some of your requests are failing is really odd.

Hi Yeurich, Im unfortunately having the same issue. :frowning:

Hi all,
Can you tell us what ISP you’re using? How are you accessing your network? Have you experienced any other network issues?

-Max B.

My ISP is UPC Ireland. It’s cable internet, I’m connected to the modem through Ethernet. I’ve not had any other issues that I can think of

Really sorry that it’s taking us so long to get to the bottom of this.

We think it as a problem with either:

  • your ISP
  • your router’s settings
  • the network settings on your PC for the specific connection to your own network (the phone test ruled out a general PC problem)

Things we’ve though of which could help narrow this down:

  1. Change from connecting via wired Ethernet to WiFi. We believe this will create a separate network config on your PC. If that works, we rule out your ISP as being part of the problem, but it could still be your router’s config of wifi vs wired connections.
  2. Borrow a router and try that in place of your own. If this works, then we know it’s something to do with the configuration on your own router.

Hi, ISP Telkom(South Africa), I’ve tried at work through a proxy, at home via Ethernet and WIFI, unfortunately unsuccessful each time.
I’ve no other issues with home network.
Tried setting up Unity as well got a similar issue using work proxy & home WIFI, but worked with home Ethernet.

Hi, no problem.
I connected through WiFi and I’m getting the same problem still.
I don’t have another router or access to one right now.

Also, I don’t know what this means in terms of the issue, but I tried connecting to the internet through a VPN service and I was able to successfully download the engine through the launcher. Would that point more to it being a problem with my ISP?