Can't download assets with Linux

Hi guys,

I’m aware that the Epic Launcher hasn’t been ported to Linux (although it’s been released to MacOS which should make it much easier to port to Linux); however, I have no way of downloading an asset I bought in the Marketplace when I’m on Linux. First, because the Launcher itself doesn’t run on it, and second, because the web-based Marketplace itself delegates the download to the Launcher via xdg-open (i.e. it tries to reach the default program to handle the specific URI protocol that the Marketplace uses). The result, then, is that if I’m on Linux I have no means whatsoever of downloading assets from the Marketplace - instead, I’m having to make my wife angry by asking to use her computer which has Windows installed, so that I can download the assets from there and manually copy them to my computer.

I mean, come on, how hard is it to put a regular download link on the vault asset page? Having a URI that launches the Launcher is totally useless, if I have a Win/Mac computer with the Launcher installed I can just download it from there. Sometimes it feels like it’s made harder on purpose for Linux users.

No intention to bash you guys. Best game engine ever, amazing job. But man, it’s also the hardest game engine to run on Linux that I’ve tried, by far.


I am actually scouring the web for how to get around this issue myself. Seem I will have to install a full blown virtual machine of windows just to download a file from a web site… this makes me very very sad, but it seems to be the only way to do it.

The same happens to me. I don’t understand how they will help the Linux developers if they don’t let us download things from a web. There are enought authentication and security on the web so that is not a security concern. They want us to force using the Launcher that I don’t really need or have the time to use because I am a full time artist/developer not a game player that does not have nothing more to do but play games. So what is the point of doing the things so stupid? Please, put some option to download directly from the web.

Thank you.

PD: I love the effort that Epic Games put on the Unreal Engine for Linux but some other things like the web need really to be improved so we can work flawlessly.

Hi guys,

were you successful with running the launcher in a virtual windows installation? I just tried this a few minutes ago, however the launcher refuses to start without a GPU and my VirtualBox is not able to pass it to the guest system. There is even an answerhub question about this problem here:…albox-gpu.html

Actually, does anyone have any solution that is working? I’ve tried the following and was not successful at all:

All of these attempts have wasted a few hours already and now I have to set up dual boot just to download assets that I’ve paid for.