Download

Can't disable shadows

Hi;

I was trying to make a grass foliage with the exact same color that the landscape but there is a “shadow” I can’t disable:
Capture.PNG
However I disabled the “cast shadow” on the mesh parameters

I get the same shadow with two cubes:
Capture1.PNG
Here too I disabled the “cast shadow” of both cubes

I don’t know where these shadows come from and how to disable it
I use a skylight and a directionnal light.

Thanks to read.

You probably have ambient occlusion on in the post processing settings.

You probably also need to modify foliage normal to be same as landscape too.

What do you mean? The normal node is blank on my landscape material and my grass material

Thanks! It progress! Now I would know is there a way to disable the shadows on the sides, I mean all the sides of the mesh being in the same colors no matter the orientations of itself or of the light.
Capture.PNG

Actually my final goal is to make the lower part of my grass “mix” with the landscape to make the seam invisible and the upper part a little brighter with a gradiant. Maybe there is a quicker way to do that

The shading in on the side is due to the vertex normals on the 3d model, you can set the vertex normals to straight up in your 3d application so the grass normals will match the ground normals.

If you leave normal node to blank then it’s automatically use vertex normal. If you use [World normal] visualization mode you clearly see discontinuation at normals. If you disable [use tangent sapce normal] for foliage and then plug constant vector3 = (0,0,1) to normal node you should see improvement.

Setting the material to 0,0,1 in world space wont help when grass is placed on a slope though.

Yeah. Full solution is just slightly more involved.
But I made example material so it should be easy to adapt.
b7400e6168da344c18562cf541aa64917ccef112.jpeg

Capture.PNG
Expected goal (almost) achieved!
Thanks to you guys!

But can my grass and my landscape receive shadows from others mesh?

Yes they can.

But they don’t :frowning:
I think it’s because of the normal manipulation, but I don’t know ligthing and normal was linked

All lighting is calculated by using pixel normal and light direction. If that scene contain normal that point upwards and light source is from the above it should work fine. Can you show visualization of world normals?

When I enable the world normal buffer the landscape and grass twinkle black and white randomly

EDIT: I noticed I forgot to change the vector3 to 0,0,1 and left it to 0,0,0, in the material
5b5c1ba51b05fb7668f1dec3ef09c27f203ee167.png

But when I change it to 0,0,1 I got this result… but indeed it receive light
Capture.PNG

I have to say my grass and my landscape doesn’t use a texture but a color with a gradiant, I don’t know if that’s important

And you clicked the main material node and set “Tangent Space Normal” to FALSE as Kalle suggested?

Yes I did with my both grass and landscape materials

Double check your transform node. It should be local to world space and you have tangent to world space.

I feel stupid… It works.
Thanks for your time, your help and your patience!