Download

Cant disable contact shadows on grass?

Havent noticed this before because my dynamic light contact shadow value was set to off.

  1. the cost for it is paid anyway regardless of what value goes in there

  2. my grass now has shadows despite the grass settings having “cast dynamic shadows” set to off.

My frame rate is around 45 to 55fps at 4k in a rather dense foliage scene. Im thinking that if i manage to actually not have these meshes cadt shadows at all i may hit the extra 10 or so i keed (very wishful thinking becuase by grass isn’t that dense).

Does anyone else have this new “engine feature”?
what can I do to get grass not to cast a dynamic shadow?..

Well, ok I wrote that maybe I could save on frames, but I guess it doesn’t matter. even disabling shadows from the directional light altogether doesn’t reduce the scene rendering cost one bit.
Still, because the shadows aren’t modulated at all I would like it if I could disable the grass shadowing…

Contact shadows are a screenspace effect, so, no, you cannot disable it easily, as the grass writes to the depth buffer due to being opaque.

I suppose I could refine the mesh for the vertex grass to the point that I have no need for opacity in the material… But from what I can see the effect is active even on solid objects like rocks.
The difference is that I’m just not used to see the very fine shadow lines from the grass - since it’s not like is costing more or less to render apparently.