Cant disable Clear Coat reflection in Path Tracing mode?

Hey

Going mad here, but whatever I do, I cant remove the reflection in pathtracer clear coat shader with dual normal mode.


I’m using IBL light source + directional light. Whatever setting I change in UE, the reflection always stays.
The reflection noral is driven by shader normal input, not ClearCoatBottomNormal.

Is this a bug?

It seems that I cant affect it by parameters, It works in Lit mode/gpu, but in pathtracer, its just locked to solid reflection. Roughness/specular/metallic does not really affect it as far as I can tell. The only thing that changes it is normal

Ok I got it figured out… “I think” It seems that in Path Tracer mode, wrong attribute is controling wrong parameter… let me try to explain :

Dual - normal mode has 2 surfaces

  1. Base
  2. Clear coat.

They split in :

  1. Base is being controlled by
    Metallic
    Specular
    Clear Coat Roughness - IT SHOULD NOT
    ClearCoatBottomNormal

  2. Clear Coat
    Clear Coat
    Normal
    Clear Coat Roughness

What this means is that in path tracer mode, if I want to change roughness of base layer, I cant, because it will also change roughness of top clear coat layer.

This happens only in Path-Tracer mode. In Lit mode everything works as it should.

Actually there are 2 bugs here.

  1. Clear_coat_Roughness controls both base&clear coat reflection roughness.
  2. There is NO way to control base reflection strenght/intensity in 1st place. Can’t set it to 0.1 or something like that to be very subtle/weak.

Can any1 confirm this?

Bump… any1 ? am I the only one with this issue?