Download

Can't deploy Google VR project to a device

So I’ve been following this tutorial along with that one and wanted to deploy a simple empty VR-ready scene to my Android phone but when I try to install the project on my device using ADB, first I get a


Failure [INSTALL_FAILED_NO_MATCHING_ABIS]

error, then a second installation (or something with a percentage progess at least) starts but ends up in yet another error - this time


Grant READ_EXTERNAL_STORAGE and WRITE_EXTERNAL_STORAGE to the apk for reading OBB file

. After that, I get


Bad argument: java.lang.IllegalArgumentException: Unknown package: com.YourCompany.CardboardVR

twice only to finally receive an


Installation successful

alert.

This isn’t true of course cause nothing new can be found on the phone after the procedure :frowning: Why is that so, how can I try to fix it? I’ve tried with both ARM versions (ARM64 is suggested in the tutorial, ARM7 is what my device actually houses so I tried one and then the other just to be sure), I’ve tried disabling all VR plugins in the editor except Google VR, I’ve also tried manually copying the .apk to my device and running it to later copy the .obb file to a corresponding folder but the .apk doesn’t even start this way.

  • Which device are you installing to?
  • Which Android version does it have?
  • Which Android SDK Target version do you have set in your android project settings?

@aussieburger

  • I’m trying to install it on my Moto X (2014 model, AKA XT1092)
  • It runs Android 6.0
  • Minimum android-24, target android-24

Seems like the issue is resolved - I’ve used a recommendation from a guy on UE4’s AnswerHub and changed the target and minimum SDK to android-19 as opposed to -24 and now it installs and runs flawlessly :slight_smile: Thanks anyway!

Correct - Android 6.0 is android-23 as per:
https://developer.android.com/about/dashboards/index.html
so anything built with android-24 target will not run on less than Android 7.0 :wink:

Oh, I see - so that’s the reason a different number made it work! Thanks a lot :slight_smile: