Can't create new C++ project: access denied

I’m trying to create a new C++ project, from a clean install of UE 4.11.2, with the latest version of Visual Studio Community 2015 installed.

I keep receiving the error: UnrealBuildTool Exception: Access to path BuildConfiguration.Schema.xsd is denied. I get the same error if I try to add a C++ class to an existing Blueprints project, too. Any ideas what could be wrong?

An error occurred while trying to generate project files.

Running C:/Program Files/Epic Games/4.11/Engine/Binaries/DotNET/UnrealBuildTool.exe  -projectfiles -project="C:/Projects/Example/Example.uproject" -game -progress -2015
UnrealBuildTool Exception: System.UnauthorizedAccessException: Access to the path 'C:\Program Files\Epic Games\4.11\Engine\Saved\UnrealBuildTool\BuildConfiguration.Schema.xsd' is denied.
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
   at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
   at System.IO.StreamWriter.CreateFile(String path, Boolean append, Boolean checkHost)
   at System.IO.StreamWriter..ctor(String path, Boolean append, Encoding encoding, Int32 bufferSize, Boolean checkHost)
   at System.IO.File.InternalWriteAllText(String path, String contents, Encoding encoding, Boolean checkHost)
   at UnrealBuildTool.XmlConfigLoader.OverwriteIfDifferent(String FilePath, String Content, Boolean bReadOnlyFile)
   at UnrealBuildTool.XmlConfigLoader.Init()
   at UnrealBuildTool.UnrealBuildTool.InitConfigurationClasses(String[] Arguments)
   at UnrealBuildTool.UnrealBuildTool.Main(String[] Arguments)

Hello chris.nolet,

From what I’ve seen previously, that error message could mean a few different things. Firstly, be sure that you’re running Visual Studio as an administrator, otherwise it won’t be able to access this file. If that doesn’t help, please check that file that it isn’t able to access and ensure that it isn’t set to “read-only”. If neither of these work, please try disabling your anti virus temporarily to see if it may be blocking Visual Studio from accessing certain files.

Edit: If none of these options help, what version of Windows are you using and have you been able to create C++ projects in Unreal previously on this same computer? If so, what version was it on?

Thanks Matthew! You were right – even though I’d deleted and reinstalled UE4 from the launcher, some files were left over, and this particular file was read-only. Deleting the entire 4.11 folder and reinstalling it fixed the issue. Thanks again :slight_smile:

thanks , the same error for me , it’ s help me