Can't create c++ script

Hey just switched from unity to unreal here. So I got unreal a few days ago and when I first downloaded it. I opened it, created a new project, and made a script. But it never worked it said something about compiling and stuff. I closed the project and when I went to open it up again it wouldn’t let me because of the script. Please help so I can use unreal.

It sounds like you made a C++ file for your project, but is has invalid code, causing the game to fail to build. You’ll need to fix the code, or remove the file to get your game to build again.

To fix the code, you’ll need to look at the Error logs and determine what code is broken.

To remove the file:

  • Remove the class .cpp and .h from Source folder that you dont want anymore
  • Right Click your .uproject file and select “Generate Visual Studio Project Files”
  • Try to open your project again.

Be careful removing the file if you are using the Cpp file as a parent inside of the game. It will break blueprints and other code that relies on it.

I make the project do nothing in it. I go make the script. Then I get the error. I quit the project and try going back in. Then I can’t open the project anymore because of the script.

Update: Oh the error is this “Windows SDK must be installed in order to build this target.” How do I get this?

Second Update: Reinstalled unreal engine and still the same error comes up

Third and final Update: It works :D. I found the download for the SDK and got it. It works good. Unreal here i come :slight_smile: