Can't connect to a port forwarded adress

I have the basic 3rd-person templete, only change is a widget with a “Host” button and a textbox with a “Join” button that lets the user type in an IP adress.

I have portforwarded the port 7777 and started two different games. Using my local IP “192.168.x.x” I can connect just fine. Even between different PC’s. However, using my global ip insted of my local I can’t connect, not even within the same machine. I’ve tried setting up a minecraft server on the port 25565 and that worked just fine. I then switched the UE4 default port to 25565 incase the 7777 port was being used and/or broken. It didnt work either.

IsMyPortOpen website says that a port is open when the minecraft server is running on 25565. But when the minecraft server is off and the UE4 game is on with a hosted session, the website says the port is closed.

I host a session with the console command “open LEVELNAME?listen” and connect to it with “open MYIP”.
I have the line:
[OnlineSubsystem]
DefaultPlatformService=Null
in the DefaultEngine.ini. Tried with =LAN also.

I’ve searched for hours but can’t find any fix for this issue. Please help me!

Thanks in advance!

Did you manage to solve this?

If yes please contact me at ceo@decodestudios.in or discord: www.decodestudios.in, name: DecodeStudios#9604

Im afraid not. I did however manage to get multiplayer working via steam, both local and global.