Can't Compile my uproject

My Problem

I used VS 2015 to write C++ Unreal Code und everthing was fine. But since recently (i think after my Windows 10 got updated) i can’t even open my C++ Editor from the Unreal Engine 4 window and i can’t compile C++ code for my uproject.

What i tried to fix it

  • I tried to uninstall VS completely (2015 and 2017) and reinstall it with the needed components (i even tried to also install the UE Installer too, but this didn’t make a difference).

  • I tried to reinstall the latest Unreal Version (4.18)

  • I tried to build it within VS2017 but i get this error:

     D:\Programme\Microsoft Visual Studio\Common7\IDE\VC\VCTargets\Microsoft.MakeFile.Targets(44,5): error MSB3075: Der Befehl ""D:\Programme\Epic Games\UE_4.17\Engine\Build\BatchFiles\Build.bat" testEditor Win64 Development "G:\Game Design\Unreal Projects\C++\test\test.uproject" -waitmutex" wurde mit dem Code 5 beendet. Stellen Sie sicher, dass Sie zur Ausführung dieses Befehls berechtigt sind.

What basically means that it seems that i don’t have the permission to run this command.

  • I tried to open the uproject direct, than this window pop’s off:


after clicking “yes” it throws an error: BuildingEscape could not be compiled. Try rebuilding from source manually.
How do i do it manually?

I got another Error that displays when i try to create a new C++ Projekt.

Maybe that error can specify my problem better?


Building manually simply means to rebuild your code from within Visual Studio itself. Usually, a common fix to most of the sudden VS issues is to regenerate and rebuild the solution. Please refer to this answer where I explain how to do this.

I just saw someone had his issue with VS resolved by installing “NuGet package manager” (AnswerHub post). Though I myself never faced such problem, it might be the cause of your issue!

Hope this helps.

First, thx for the fast answer Vizgin.
I tried to follow your instructions and the “NuGet package manager” was already installed/checked, but neither of these solutions fixed my problem :frowning:

Hello Sodrek,

One thing I can think of to check:

Make sure that all files in your project are NOT read-only. (In the past using source control has locked the files and I had the permissions error)

Hope this helps,

How do i do it correctly?

Right click on your project folder in windows explorer → Properties → Uncheck Read-only → Apply → Apply to subfolders/files.

okay, than i did it already and it didn’t worked :confused: i also tried to do it with the 4.18 engine folder and subfolders but this take a really long time to load.

I got it finally by downloading an VS total uninstaller, uninstall every Engine Version installed, VS and even the Epic Games Launcher. Than i download VS 2017 again and checked the “UE Installer” option, installed the latest engine version and it worked. Thx for the help so far!