Can't Compile FloatingActor Tutorial

When I follow the instructions for compiling the floating actor tutorial, I am unable to actually compile it. I get the following error and have been unable to troubleshoot it. How can I resolve this?

Info Running Mono…
Info Setting up Mono
Info /Users/Shared/UnrealEngine/4.9/Engine /Users/Shared/UnrealEngine/4.9/Engine/Binaries/Mac
Info Compiling game modules for hot reload
Info ERROR: System.ArgumentOutOfRangeException: < 0 || >= this.Length
Info Parameter name: startIndex
Info at System.String.LastIndexOf (Char value, Int32 startIndex, Int32 count) [0x00000] in :0
Info at UnrealBuildTool.UnrealBuildTool.PatchActionHistoryForHotReloadAssembling (System.Collections.Generic.List`1 OnlyModules) [0x00000] in :0
Info at UnrealBuildTool.UnrealBuildTool.RunUBT (System.String[] Arguments) [0x00000] in :0

Happening to me when I hit compile on UEditor in OS X.

Well I was having this problem on OS X and UE4 Version: 4.9.1-2689999+++depot+UE4-Releases+4.9.

I solved my problem closing the editor then going to the launcher → unreal engine → library → the menu of my install and hitting verify which backed up a /Users/Shared/UnrealEngine/Launcher/Backup/UE_4.9[2015.10.07-00.26.30]/Engine/Programs/UnrealBuildTool/BuildConfiguration.xml but after the verify, I could add a second C++ file and it did build from within the editor.

Hey botsupi-

Was tyoc213’s solution of verifying the engine install helpful for you? If you’re still having issues compiling the project can you indicate where in the tutorial you encountered this problem?

I reinstalled Unreal Engine and that solved the problem. If I encounter it again, I will try the verify step first.

commenting out the line that says “PrivateDependencyModuleNames.AddRange(new string[] { });”
in Source/MyProject/MyProject.Build.cs.