Can't compile C++ project for Android

Hi RumbleMonk,

UE 4.16 unsupported Visual Studio 2013. If you using 2015 or 2017 can you check c++ toolchain. For this go to Control Panel > Program Add & Remove > Microsoft Visual Studio > Modify.

Thanks for the reply, what am I looking for here exactly? I’m using 2015, the features that are used in my installation are all 3 options under Visual c++ (common tools, foundation classes, windows xp support).

The options under cross platform mobile development are not checked however, that does sound like something to look into…?

I am getting these errors when trying to package for Android:

UATHelper: Packaging (Android (ETC2)): UnrealBuildTool: ====6/10/2017 7:38:26 PM====PREPARING TO MAKE APK=================================================================
UATHelper: Packaging (Android (ETC2)): UnrealBuildTool: ERROR: System.ComponentModel.Win32Exception (0x80004005): The system cannot find the file specified

I have set the Android SDK config in the project settings, this is my first effort to try to compile it but not sure what’s going on. Any help would be appreciated.

Full log here:

link text

Okey enought only c++ option. Can you install windows 8.1 or 10 sdk. And can you share me android sdk options in ue4 editor.

I have followed the steps at [link text][2], which as far as I know should be enough for a windows 10 SDK?

Oh, so again - I’m new to C++ compiling for UE4, I tried setting ‘solution configurations’ to shipping then rebuilding my game from VS2015. The rebuild was all fine, when compiling in UE I still get the same error message;

ERROR: System.ComponentModel.Win32Exception (0x80004005): The system cannot find the file specified

Does it even matter what I do in Visual Studio? I’d imagine packaging in UE4Editor will run everything again anyway… I feel lost.

Can you try empty project with compile ?

link text

This is a test from the ‘c++ basic code’ template with minimal content. Still the same error. All I did was go to project settings - platforms - android then hit ‘configure now’ for APKPackaging.

I have spaces in my paths (again, using win10) - might that be part of the problem? My projects are inside ‘unreal projects’ folder and UE4 installations in the default.

The problem is definitely not the project. But I could not figure out another solution. Sorry.

I tried creating a project in C:\UnrealProjects and got the same thing - space in the folder is not the problem, same error.