Can't click HUD buttons after adding it to viewport

Hi everyone.

I have in screen a touch interface blueprint and a Widget Blueprint and I need both to interact to different touches but when I add the widget to the screen I activate and then i move it to the background has seen in the lower code.


But when in the game I try to touch the buttons on the widget, they are completely disabled and can’t be reached by the screen taps, but the interface blueprint does react when you touch it, any help with this issue would be greatly appreciated.

Are you trying to make it so that both of them are active at the same time? If so, they should be on the same Z-Order value (ie both -15 in this case)

Using blueprints, you need to enable a “Set Input Mode UIOnly” node with the UI widget in focus.

Not sue how to do that in C++

HI Mookies, how can I set both of them to the same Z-Order Value, I can’t seem to get a way to access the Virtual Joystick, I only have a reference to my Widget, thanks for your help.

Ah sorry, I think I read your question wrong. Could you provide a screenshot of the designer tab of your widget please?

Yes, of course, here is the screenshot.

And here is a screenshot of the game during play:

is currentHUD in your code, by any chance, the name of your widget? Try changing




Hi Mokkiez, sorry for not responding before, I tried what you told me to do but when I add it into the 0 position, both the joystick and the buttons don’t work. Any other idea of how this could be solved?

Hi Wolf, sorry you’re still having issues.

What you’re going to want to do is, after adding the UMG to viewport at 0 Z-Order, revert (in your PlayscreenHUD UMG) the Visibility back to ‘Self Hit Test Invisible’

Hi Mookiez.

Like you told me after I added the UMG to Viewport at Z-Order (0), I set the visibility to ‘Self Hit Test Invisible’, I tried also the other options of self hit but they won’t react to any input I pass using the mouse or touch screen from my mobile, but the Joystick was re-enabled, any idea how I can have both react to the inputs?

Hi Mookiez, do you have any idea of what could help me with this issue?

Oh boy, you’re still having issues? Sorry about that, I thought I recreated the issue and figured it out on the last comment. I have to say I’m not quite sure anymore. I recommend you get the attention of a staff member or someone similar who has more knowledge about this than I do

I just faced this problem too. What worked for me was to add a crazy high negative number in the widget that didnt have any interaction with the user. I approached it by having a custom base widget class where I specify it through the widget editor.