Can't change streaming method

I can’t change streaming method of my levels , the option is just not shown when i right click on my level.

Nobody knows?

I encountered this problem too.

It turned out that when World Settings->Enable World Composition is enabled you can’t use level streaming.

I’m still learning but my theory is because world composition allows you to create distinct layers for your map (Sound, audio, etc) but they are all fundamental pieces. Whereas for level streaming they’re distinct maps.

I am curious to see whether you can have level streaming at the top level and have each sub-level enable world composition to contain layers.

INcorrect, the whole idea being world comp IS streaming, because if you didn’t have it, nobody could run your projects.

"World Composition has been designed to simplify managing large worlds. One of the goals is to avoid using a persistent level to store streaming information as it becomes a bottleneck when a team of level designers want to work on levels simultaneously. The persistent level does not store any streaming information and instead scans a folder and treats all found levels as streaming levels. Each streaming level has information stored in the package header, which World Composition can read without loading the level into memory. Initially, all levels except the persistent level are unloaded in World Composition. You can load or unload any part of the world manually at any time… "…ser/index.html .

I’ve been having the same issue, and I can’t for the life of me figure it out.

I’m trying to load a level after a button press, and it just loads at the same time as the main menu, which is my persistent level.
I tried turning World Compositing off, but I can’t use the LoadStreamLevel node at all then. Will post how and if I sort this out.


Yes, to stream levels at gameplay the Enable World Composition NEEDS to be off, since that is used for multiple parties working on level development, and not to enable Loading Stream Levels during gameplay.

Steps to make you able to load load stream levels on demand:

  1. Turn Enable World Componsition OFF
  2. In the Levels window ( under Window->Levels ) add the wanted level(s) to the persistent level
  3. Right click on the sublevels -> Change Streaming Method -> Blueprint
  4. Use Load Stream Level node in Blueprints

Because the default setting for level streaming is to Always load the sublevels with the persistent level, it makes it hard to make any mechanics to work with it, and because of that you need to set it to stream by Blueprint ( to make you HAVE to load the level manually ) whenever you want to have it loaded.

Hope this helps anyone wondering like I myself was, and it was a proper pain to find any specific information about it.