Can't build HLODs without running out of video memory

Hi, I have an 8gig video card but I can’t seem to build HLODs without running out of video memory and crashing. Anything I can do?


In order to reduce the video memory consumption when building the HLODs, you can reduce the engine scalability settings to reduce the strain on the video card

Hope this helps!

1 Like

Still Happens even on low :confused: I have an RX 6600 if it makes a difference.

I did some research about the problem, it seems to be a bug regarding UE5, when building HLODs, the editor crashes. Maybe you could try the latest version of Unreal (5.0.2), it seems that the problem is fixed in this version. If the problem continues whatsoever, you can report this bug filling the form on the attached link:

Hope this helps!

I have 5.0.2. So I was using the experimental water plugin. When I disabled hlods on the water, and clicked build, it didn’t crash, but it also didn’t seem to do anything? It looks like hlods are working on my foliage, is there anyway to confirm?

Yes, you can confirm if the HLOD is working by going to “Level of detail coloration” and selecting “Hierarchical LOD coloration” as shown on the following image

If the HOLDs are working, you should see colors on the assets with HLOD

1 Like

Hmm… All my trees and grass are black, I guess it’s not working? I can see them cycling through lods though when I move. Ugh very frustrating

If you are seeing the assets cycling through LODs while in “Hierarchical LOD coloration” mode, it means that the HLOD is working on those assets

1 Like

Ok, they must get built automatically through the foliage system or something. Thanks for the help