Cannot view C++ subdirectories with Sources Panel Hidden in Content Brow

Version:
4.16.3

Bug:
When creating a subdirectory with the sources panel hidden. It is impossible to view the subdirectory in the content browser.

Reproduction:

  1. Create a Basic Code C++ project with no Starter Content
  2. Ensure sources panel is minimized.
  3. Under Content Browser: Add New → Add C++ Class
  4. Choose Pawn
  5. Under Path append any “subdir/” name, where ‘subdir’ is the name of your subdirectory.
  6. Under Content Browser: Click ‘Choose path’ IE folder icon.
  7. Select C++ Classes OR MyProject4 OR ‘subdir’ created earlier
  8. Attempt to navigate to contents of ‘subdir’ by clicking in Content Browser. You should not be able to view the ‘subdir’ folder in the Content Browser.
  9. Enable Sources Panel (Note: Icon just below ‘Add New’, left hand side). Everything works.

Hey redfeather_-

Thank you for submitting a bug report. I have reproduced this issue and logged a report for it here Unreal Engine Issues and Bug Tracker (UE-49760) . You can track the report’s status as the issue is reviewed by our development staff. Please be aware that this issue may not be prioritized or fixed soon.

Cheers

Doug Wilson

Awesome, thanks Doug!