Cannot update Project's engine version

Hello Everyone

I’m trying to update my project’s engine version from 4.12.5 to 4.15.1 but engine return this error during the operation

The project could not be compiled. Would you like to open it in Visual Studio?

Running H:/UT/UE_4.15/Engine/Binaries/DotNET/UnrealBuildTool.exe Lequill Development Win64 -project="C:/Users/Alexa/OneDrive/Documents/Unreal Projects/Lequilloriginal 4.15/Lequill.uproject" -editorrecompile -progress -NoHotReloadFromIDE
Creating makefile for Lequill (no existing makefile)
Performing full C++ include scan (no include cache file)
@progress push 5%
@progress pop
Performing 4 actions (4 in parallel)
[2/4] Resource PCLaunch.rc
[1/4] Resource ModuleVersionResource.rc.inl
[3/4] Link UE4Editor-Lequill.dll
[4/4] Link UE4Editor-Lequill.lib
   Creating library C:\Users\Alexa\OneDrive\Documents\Unreal Projects\Lequilloriginal 4.15\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-Lequill.lib and object C:\Users\Alexa\OneDrive\Documents\Unreal Projects\Lequilloriginal 4.15\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-Lequill.exp
LINK : error LNK2001: unresolved external symbol _DllMainCRTStartup
C:\Users\Alexa\OneDrive\Documents\Unreal Projects\Lequilloriginal 4.15\Binaries\Win64\UE4Editor-Lequill.dll : fatal error LNK1120: 1 unresolved externals
ERROR: UBT ERROR: Failed to produce item: C:\Users\Alexa\OneDrive\Documents\Unreal Projects\Lequilloriginal 4.15\Binaries\Win64\UE4Editor-Lequill.dll
Total build time: 3,70 seconds (Local executor: 0,00 seconds)

What does it means?? I can I solve??

Very grateful :slight_smile:

Hey Alexander-

Were you upgrading the project by opening the 4.15 project launcher and creating a copy of the project or right clicking on the .uproject and selecting Switch Engine Version? Also, let me know if you’re able to upgrade the project through consecutive versions (4.12 to 4.13 to 4.14 to 4.15). Let me know if you run into any issues in this process.

Hi Doug, this error is returned when trying to update the engine opening the 4.15 and making a copy of the project.
If I try to change the versione of the engine by right clicking on the.uproject he tells me
" The following modules are missing or built with a different engine version_
UE4Editor-Lequill.dll
Would you like to rebuild them now??"

After clicking yes return this message:“Lequill could not be compiled. Try rebuild from source manually.”

I’ve tryied to rebuild the VS Solution but hit doesn’t work and returned:

The “Unresolved Externals” error appears to be caused by the use of MainCRTStartup. I’m not sure if this is a plugin or module you’re using with your project, but can you try disabling/removing it and try to upgrade the project again? If this is a module you’re using with your project, you may need to update the Build.cs file. Additionally, let me know if you’re able to upgrade the project one version at a time (4.12 to 4.13 to 4.14 to 4.15) rather than jumping from 4.12 to 4.15.

Cheers

Doug Wilson

I’ve done, just added a c++ class in the project, changed the engine version rightclicking on the .project 4.12 to 4.15 directly, manually rebuild with visual studios and done. It’s strange, previous version doen’t need to build code for the upgrade, not this way.

Don’t know what I wrote is comprehensible.

Thanks for your patience ??

Cheers

first revert back to 4.12 (right click on .uproject and switch to 4.12) and ensure the project is still working there. Then try converting up through each engine version, testing the project in each version to see if it breaks prior to 4.15. Also try to remove any reference to MainCRTStartup in your code if possible as this seems to be generating the error.