Cannot rebuild Project.dll

Hello, I cannot seem to get any projects made with C++ code to work. After a while of using them (Or sometimes immediately) I get an error saying 'The following modules are missing or built with a different engine version: UE4Editor-MyProject.dll Would you like to rebuld them now?" if I click yes another error shows up saying “MyProject could not be compiled. Try rebuilding from source manually” This happens if I run it from the Unreal Engine, or from visual basic, or if I just click on the Uproject file. I’ve tried deleting the visual basic files and rebuilding them. I’ve tried rebuilding the files in debug-editor and development-editor. I have tried returning my code to a known good state and that does not work. This has happened so many times now and I do not know how to fix it.

I had a very similiar problem, did you try to delete the intermediate folder and then rebuild your project from source?
Perhaps this solution mentioned here can help you: Dll.response missing - Programming & Scripting - Unreal Engine Forums

I know how frustrating this can be.

Okay, I’ve tried that out and it did not help.

You should post your output log. Also, it’s Visual Studio, not basic. Visual Basic is another programming language. :slight_smile:

Yes, I always mix those two up :stuck_out_tongue: There is no output log since I cannot get it to run in either visual studio or UE4.

I also had this problem but it was due to the fact I used a previous project to build off of. I needed to right click my .uproject file and edit the name like so: