Cannot package game when upgraded to 4.12

Hello Community, I am having some trouble packaging in version 4.12.2, i could package in 4.11. here is the error log and the log txt if youd like to see it.

MainFrameActions: Cooking (Windows): CommandUtils.Run: Run: Took 46.5062232s to run UE4Editor-Cmd.exe, ExitCode=1
MainFrameActions: Cooking (Windows): Project.Cook: Cook failed. Deleting cooked data.
MainFrameActions: Cooking (Windows): Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.AutomationException: Cook failed. —> AutomationTool.AutomationException: BUILD FAILED: Failed while running Cook for H:\GameDev\p4v_repos\riuthamus_pastryFortress_DevStage_pcMa
MainFrameActions: Cooking (Windows): in\ProjectPastry.uproject; see log C:\Users\daren\AppData\Roaming\Unreal Engine\AutomationTool\Logs\G+Program+Files+(x86)+Epic+Games+4.12\Cook-2016.06.11-11.44.01.txt
MainFrameActions: Cooking (Windows): at AutomationTool.CommandUtils.RunCommandlet(FileReference ProjectName, String UE4Exe, String Commandlet, String Parameters)
MainFrameActions: Cooking (Windows): at Project.Cook(ProjectParams Params)
MainFrameActions: Cooking (Windows): — End of inner exception stack trace —
MainFrameActions: Cooking (Windows): at Project.Cook(ProjectParams Params)
MainFrameActions: Cooking (Windows): at BuildCookRun.DoBuildCookRun(ProjectParams Params)
MainFrameActions: Cooking (Windows): at AutomationTool.BuildCommand.Execute()
MainFrameActions: Cooking (Windows): at AutomationTool.Automation.Execute(List1 CommandsToExecute, CaselessDictionary1 Commands)
MainFrameActions: Cooking (Windows): at AutomationTool.Automation.Process(String[] CommandLine)
MainFrameActions: Cooking (Windows): at AutomationTool.Program.MainProc(Object Param)
MainFrameActions: Cooking (Windows): at AutomationTool.InternalUtils.RunSingleInstance(Func`2 Main, Object Param)
MainFrameActions: Cooking (Windows): at AutomationTool.Program.Main()

And the output file

https://dl.dropboxusercontent.com/u/41065/Cook-2016.06.11-11.21.36.txt

Hello,

I see a few errors in your logs:

Ensure condition failed: AttachmentRules.LocationRule == EAttachmentRule::KeepRelative && AttachmentRules.RotationRule == EAttachmentRule::KeepRelative && AttachmentRules.ScaleRule == EAttachmentRule::KeepRelative [File:D:\Build++UE4+Release-4.12+Compile\Sync\Engine\Source\Runtime\Engine\Private\Components\SceneComponent.cpp] [Line: 1482]
AttachToComponent when called from a constructor is only setting up attachment and will always be treated as KeepRelative. Consider calling SetupAttachment directly instead.

That ensure can be seen in your Output Log, the message also details suggestions on how to resolve it.

Also:

[2016.06.11-21.15.00:923][ 0]LoadErrors: Info Failed to load /Game/Meshes/Props/Traps/turret_base_01_pCylinder16_Skeleton.turret_base_01_pCylinder16_Skeleton Referenced by turret_base_01_pCylinder16
[2016.06.11-21.15.00:924][ 0]LogUObjectGlobals:Warning: Failed to load ‘/Game/Meshes/Props/Traps/turret_base_01_pCylinder16_Skeleton’: Can’t find file ‘/Game/Meshes/Props/Traps/turret_base_01_pCylinder16_Skeleton’
[2016.06.11-21.15.00:924][ 0]LogLinker:Warning: Can’t find file for asset ‘/Game/Meshes/Props/Traps/turret_base_01_pCylinder16_Skeleton’ while loading NULL.[2016.06.11-21.15.00:924][ 0]LoadErrors: Info Failed to load /Game/Meshes/Props/Traps/turret_base_01_pCylinder16_Skeleton.turret_base_01_pCylinder16_Skeleton Referenced by turret_base_01_pCylinder16

I see can’t find file errors, which usually refers to an asset that no longer exists, but contains references in blueprints or code. Ensure that you don’t have any unnecessary references in your blueprints that are looking for assets that no longer exist.

Let me know if you have any other issues after looking through the log and resolving these error messages.

Have a great day

Thanks for your answer, but we got it figured out. Warnings from using attachtocomponent or setupattchment reguarding the constructor caused the cook not to complete in the packaging process! Hope this helps others!

Hello CyberblastSoft,
I´m currently running into the same problem as you but even after trying other methods for attaching Components like “AttachTo”, “SetupAttachment” or “AttachToComponent” the error stays.

Did you manage to solve the problem and if yes, how did you do it?

Thank you and have a great day

Hello,

I have the same problem and its trouble me for days, I know that the error is because i use something like attachTo in the constructer but ive removed from all the code ,compiled with no warnings or errors but its still giving me the same error on packing for Winx64.What else i have to do to catch this error? I’ve also looking into my BP classes but i couldn’t find any that uses constructor.Any adviced what should I do?I’ve tried to start from all over with a new project then added my files from old project and ive removed some of the imported files,thats why im getting so many warnings.I’ve attached the packing log below

I’m sry the first link doesn’t work please check this one