Cannot package for Android

To start off I have not installed Android Works as I like my manual setup and have Android Studio so I already have the SDKs installed:

  • android-ndk-r10e
  • apache-ant-1.9.6
  • jdk1.8.0_60
  • and android-sdk with API level 16, 22 and 23 installed.

All paths correctly setup in Project Settings with “android-16” API Level set for the NDK and “matchndk” for the SDK.

When trying to package for Android, any of the platforms, I get the output below. I’m testing this with the TappyChicken 4.9 project without any alterations except setting up the SDK paths.

Any ideas why I cannot get this to work?

EDIT: Full output log is attached

Hello Ruudscorner,

In order to better assist you, I will need the full output log from the editor showing the full error log. Please provide that to me as a .txt format that I can simply download from AnswerHub.

Looking forward to hearing back from you, thanks!

Thanks. Added the full output log to the original post.

Hey Ruudscorner,

Please update your API to 19, it should say SDK API Level “latest” and NDK API Level “android-19”.

Please review this forum post for further clarification.

Unfortunately it gives the same error.

Hey,

You must follow these steps and install AndroidWorks in order to package and deploy on an Android device. Once you’ve done that, as long as everything else is set up correctly with your Android settings, it should package properly.

Please upload your logs if you run into another issue, even if it appears to be the same issue.

Thanks!

Thanks. Then I understand you have to use AndroidWorks - which is a clunk of a package. I will unfortunately consider it a flaw in Unreal Engine that it can’t handle “native” Android SDKs and NDKs. I hope this will be fixed in future versions.

Try running the engine in “administrator” mode. This was what fixed the issue with me when nothing else was working!!

this video should help.

This worked for me. Thanks.

If anyone still has a problem (as the above did not work for me), please follow this guide: Physica Games - Unreal Engine V4.14 Cannot Deploy to Android

Can someone help me
Keep getting the same error messages again again and again, no matter what i do this keeps happening
link text

UATHelper: Packaging (Android (Multi:ASTC,DXT,ETC2)): ERROR: cmd.exe failed with args /c "E:\Users\FiercePC\Documents\Unreal Projects\SpaceEscape\Intermediate\Android\arm64\gradle\rungradle.bat" :app:assembleDebug
UATHelper: Packaging (Android (Multi:ASTC,DXT,ETC2)):        (see C:\Users\crick\AppData\Roaming\Unreal Engine\AutomationTool\Logs\H+Games+UE_4.25+UE_4.25\Log.txt for full exception trace)
PackagingResults: Error: cmd.exe failed with args /c "E:\Users\FiercePC\Documents\Unreal Projects\SpaceEscape\Intermediate\Android\arm64\gradle\rungradle.bat" :app:assembleDebug
UATHelper: Packaging (Android (Multi:ASTC,DXT,ETC2)): AutomationTool exiting with ExitCode=1 (Error_Unknown)
UATHelper: Packaging (Android (Multi:ASTC,DXT,ETC2)): BUILD FAILED
PackagingResults: Error: Unknown Error

link text